题目描述

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

输入格式

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

输出格式

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

输入样例

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

输出样例

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

《算法笔记》中AC答案

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1010;
int toll[25]; //资费
struct Record {
char name[25]; //姓名
int month, dd, hh, mm; //月份,日,时,分
bool status; //status==true表示该记录为on-line, 否则为off-line
} rec[maxn], temp; bool cmp(Record a, Record b) {
/* strcmp(str1, str2)
如果返回值 < 0,则表示 str1 小于 str2。
如果返回值 > 0,则表示 str2 小于 str1。
如果返回值 = 0,则表示 str1 等于 str2。
*/
int s = strcmp(a.name, b.name);
if(s != 0) return s < 0; //优先按姓名字典序从小到大排序
else if(a.month != b.month) return a.month < b.month; //按月份从小到大排序
else if(a.dd != b.dd) return a.dd < b.dd; //按日期从小到大排序
else if(a.hh != b.hh) return a.hh < b.hh; //按小时从小到大排序
else return a.mm < b.mm; //按分钟从小到大排序
} void get_ans(int on, int off, int& time, int& money) {
temp = rec[on];
while(temp.dd < rec[off].dd || temp.hh < rec[off].hh || temp.mm < rec[off].mm) {
time++; //该记录总时间加1min
money += toll[temp.hh]; //话费增加toll[temp.hh]
temp.mm++; //当前时间加1min
if(temp.mm >= 60) { //当前时间书到达60
temp.mm = 0; //进入下一个小时
temp.hh++;
}
if(temp.hh >= 24) { //当前小时数到达24
temp.hh = 0;
temp.dd++;
}
}
} int main() {
#ifdef ONLINE_JUDGE
#else
freopen("1.txt", "r", stdin);
#endif // ONLINE_JUDGE
for(int i = 0; i < 24; i++) {
scanf("%d", &toll[i]); //资费
}
int n;
scanf("%d", &n); //记录数
char line[10]; //临时存放on-line或off-line的输入
for(int i = 0; i < n; i++) {
scanf("%s", rec[i].name);
scanf("%d:%d:%d:%d", &rec[i].month, &rec[i].dd, &rec[i].hh, &rec[i].mm);
scanf("%s", line);
if(strcmp(line, "on-line") == 0) {
rec[i].status = true; //如果是on-line,则令status为true
} else {
rec[i].status = false; //如果是off-line,则令status为false
}
}
sort(rec, rec + n, cmp); //排序
int on = 0, off, next; //on和off为配对的两条记录,next为下一个用户
while(on < n) { //每次循环处理单个用户的所有记录
int needPrint = 0; //needPrint表示该用户的所有记录
next = on; //从当前位置开始寻找下一个用户
while(next < n && strcmp(rec[next].name, rec[on].name) == 0) {
if(needPrint == 0 && rec[next].status == true) {
needPrint = 1; //找到on,置needPrint为1
} else if(needPrint == 1 && rec[next].status == false) {
needPrint = 2; //在on之后如果找到off,置needPrint为2
}
next++; //next自增,直到找到不同名字,即下一个用户
}
if(needPrint < 2) { //没有找到配对的on-off
on = next;
continue;
}
int AllMoney = 0; //总共花费的钱
printf("%s %02d\n", rec[on].name, rec[on].month);
while(on < next) { //寻找该用户的所有配对
while(on < next - 1
&& !(rec[on].status == true && rec[on + 1].status == false)) {
on++; //直到找到连续的on-line和off-line
}
off = on + 1; //off必须是on的下一个
if(off == next) { //以及输出完毕所有配对的on-line和off-line
on = next;
break;
}
printf("%02d:%02d:%02d ", rec[on].dd, rec[on].hh, rec[on].mm);
printf("%02d:%02d:%02d ", rec[off].dd, rec[off].hh, rec[off].mm);
int time = 0, money = 0; //时间,单次记录花费的钱
get_ans(on, off, time, money); //计算on到off内的时间和金钱
AllMoney += money; //总金额加上该次记录的钱
printf("%d $ %.2f\n", time, money / 100.0);
on = off + 1; //完成一个配对,从off+1开始找下一对
}
printf("Total amount:$%.2f\n", AllMoney / 100.0);
}
return 0;
}

最新文章

  1. NSURLSessionTask使用dispatch_semaphore 完成同步机制
  2. 交叉编译inetutils并配置telnet服务
  3. Java中UIManager的几种外观的详细讲解
  4. 【eoe 6】ActionBar的使用
  5. ————————————————————————————杭电ACM————————————————X-POWER————————————————————————————————
  6. 【转】Deprecated: Function ereg_replace() is deprecated的解决方法
  7. cf 605A Sorting Railway Cars 贪心 简单题
  8. SpriteKit游戏开发
  9. [LeetCode 120] - 三角形(Triangle)
  10. css3的box-sizing
  11. STM32片上Flash内存映射、页面大小、寄存器映射
  12. jQuery 学习总结(上)
  13. spark运算结果写入hbase及优化
  14. vue如何使用rules对表单字段进行校验
  15. [uboot] (第四章)uboot流程——uboot编译流程
  16. java mvc spring boot
  17. Android开发教程之【环境搭建及HelloWorld】(转载)
  18. 用 C 语言描述几种排序算法
  19. js中的deom ready执行的问题
  20. antlr提取代码注释

热门文章

  1. Java 面试题 四
  2. wgs84 转百度经纬度坐标
  3. ORACLE表名与列名小写转成大写
  4. 【转】mysql基础汇总
  5. SchedulerFactoryBean的问题
  6. Jinja2学习
  7. nginx实现负载均衡、缓存功能实战
  8. cmd ora-12560协议适配器错误
  9. ycache中redis主备功能设计及使用说明
  10. 带你体验Android自定义圆形刻度罗盘 仪表盘 实现指针动态改变