题目大意:有一个h*w的公告榜,可以依次在上面添加信息。每个信息的长度为x,高为1.

优先在最上面加入,如果空间足够的话,然后优先放在最左面。统计每条公告最终的位置,即它所在的行数。

这里是线段树来存储 当前区间(i,j)的所有位置,剩余的最大空间。 初始化即为w,公告榜的宽。

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

 
Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

 
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 
Sample Input
3 5 5
2
4
3
3
3
 
Sample Output
1
2
1
3
-1
 
#include <iostream>
#include <stdio.h>
using namespace std; int tree[1000000]; // 记录当前区间所有位置,剩余的最大空间
int h,w,n,t; int max(int a,int b){
return a > b ? a : b;
}
void build(int l,int r,int k) {
tree[k] = w;
if (l == r) return ;
int m = (l + r) >> 1;
build(l,m,k*2);
build(m+1,r,k*2+1);
}
void update(int t,int l, int r, int k){
if(t > tree[k]){ // 如果当前无法加入,就直接返回
printf("-1\n");
return;
}
if(l == r){ //说明找到了合适位置可加入。
printf("%d\n", l);
tree[k] -= t;
return;
}
int m = (l+r)/2;
if(t <= tree[k*2])
update(t, l, m, k*2); //优先加入左子树,即上面
else if(t <= tree[k*2+1])
update(t, m+1, r, k*2+1);
tree[k] = max(tree[k*2], tree[2*k+1]);
} int main() {
//freopen("in.txt", "r" ,stdin);
while(scanf("%d %d %d", &h, &w, &n) != EOF){
if(h > n)
h = n;
build(1,h,1);
while(n--){ //更新
scanf("%d", &t);
update(t, 1, h ,1);
}
}
return 0;
}

最新文章

  1. 解读ASP.NET 5 &amp; MVC6系列(15):MvcOptions配置
  2. ueditor .net版本上传图片功能配置
  3. Hadoop的数据输入的源码解析
  4. [Asp.net mvc]jquery.form.js无刷新上传
  5. Python画图笔记
  6. spring源码分析之spring-web http详解
  7. WCF - Developers Tools
  8. Linux操作系统分析 ------------------中国科技大学
  9. mysql删除数据库报错及解决方法
  10. UIScrollView方法 属性详解
  11. Scrapy研究和探索(七)——如何防止被ban大集合策略
  12. HTML通过事件传递参数到js一
  13. ListView ,recycleView列表带进度条
  14. golang 内存模型
  15. 容器云技术选择之kubernetes和swarm对比
  16. Python之缩进块
  17. Go Example--排序
  18. shiny: Web Application Framework for R
  19. mysql不会使用索引,导致全表扫描情况
  20. 无法创建.gitignore文件,提示必须输入文件名称

热门文章

  1. What Can I Do With This Major?
  2. [jobdu]用两个栈实现队列
  3. 第九章 Mass Storage设备
  4. 微小说《tree》
  5. Visual Studio 那些隐藏的调试功能(转)
  6. Android fragment 回调函数改进
  7. 安装gem invalid date format in specification错误的解决方法
  8. Inventory &gt; INV.MTL_MATERIAL_TRANSACTIONS Show Error Msg: ORA-20100: File lxxx.tmp creation for FND_FILE failed.
  9. Hibernate包及相关工具包下载地址
  10. Asp.net性能优化技巧