Paths on a Grid

Time Limit: 1000MS Memory Limit: 30000K

Total Submissions: 23008 Accepted: 5683

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he’s explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let’s call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:

Really a masterpiece, isn’t it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4

1 1

0 0

Sample Output

126

2

Source

Ulm Local 2002

从(0,0)走到(n,m)总共需要你n+m步,其中n步向右,m步向左,问题就转化为n+m步中选n步向右的方法或选m步向上的方法,(两种方式等价).注意处理数据超范围的问题

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std; typedef unsigned long long LL; const int MAX = 1e5+10; int main()
{
LL n,m;
LL sum;
LL up,dn;
while(scanf("%I64u %I64u",&n,&m)&&(n||m))
{
sum=n+m;
n=min(n,m);
up=1;
dn=1;
for(LL i=1,j=sum;i<=n;i++,j--)
{
up*=j;
dn*=i;
if(up%dn==0)
{
up/=dn;
dn=1;
}
}
printf("%I64u\n",up);
}
return 0;
}

最新文章

  1. Laravel学习笔记(一)安装配置开发环境
  2. NOIP模拟赛-护花
  3. 拼图 canvas分割 dom拖拽 pc 移动端
  4. Django如何搭建服务器
  5. 转:GCC,LLVM,Clang编译器对比
  6. 中断服务程序不用interrupt关键字也可实现中断,该关键字是否必须?
  7. ubuntu下管理android手机
  8. [IOS]UIWebView实现保存页面和读取服务器端json数据
  9. CentOS 6.3 安装 samba 共享(转)
  10. spring+hibernate中的Result object returned from HibernateCallback isn&#39;t a List
  11. AngularJS进阶(三十三)书海拾贝之简介AngularJS中使用factory和service的方法
  12. LIRe 源代码分析 2:基本接口(DocumentBuilder)
  13. Mesos源码分析(11): Mesos-Master接收到launchTasks消息
  14. Node.js(day2)
  15. 二维码编码与解码类库ThoughtWorks.QRCode
  16. js多物体运动之淡入淡出效果
  17. PHP5.3的编译扩展
  18. vs code 的背景颜色主题还有背景图片的自定义方法
  19. PHP 连接oracle
  20. 在T-SQL语句中访问远程数据库

热门文章

  1. Java基础之读文件——使用缓冲读取器读取文件(ReaderInputFromFile)
  2. mysql:sql行列转换
  3. Tomcat类加载器机制
  4. spring 小结
  5. c++ template怎么使用及注意事项
  6. j2ee Servlet、Filter、Listener
  7. SQL 简单查询语句 select
  8. ACdream 1104 瑶瑶想找回文串(SplayTree + Hash + 二分)
  9. CCF真题之相反数
  10. ViewModel在MVC3中的应用:一个view显示多个model