Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3918    Accepted Submission(s):
1340

Problem Description
A palindrome is a symmetrical string, that is, a string
read identically from left to right as well as from right to left. You are to
write a program which, given a string, determines the minimal number of
characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be
transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer
than 2 characters does not produce a palindrome.

 
Input
Your program is to read from standard input. The first
line contains one integer: the length of the input string N, 3 <= N <=
5000. The second line contains one string with length N. The string is formed
from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and
digits from '0' to '9'. Uppercase and lowercase letters are to be considered
distinct.
 
Output
Your program is to write to standard output. The first
line contains one integer, which is the desired minimal number.
 
Sample Input
5
Ab3bd
 
Sample Output
2
题意:最少向字符串中添加几个字符可以使该字符串变成回文字符串
题解:将字符串反转,跟原字符串使用LCS,算出最长公共子序列长度,拿总长度减去最长公共子序列长度就是答案
#include<stdio.h>
#include<string.h>
#define MAX 5010
#define max(x,y)(x>y?x:y)
char s1[MAX],s2[MAX];
int dp[2][MAX];
int main()
{
int i,j;
int t;
while(scanf("%d",&t)!=EOF)
{
scanf("%s",s1);
for(i=t-1,j=0;i>=0;i--)
s2[j++]=s1[i];
memset(dp,0,sizeof(dp));
for(i=1;i<=t;i++)
{
for(j=1;j<=t;j++)
{
dp[0][j]=dp[1][j];
dp[1][j]=dp[2][j];
if(s1[i-1]==s2[j-1])
dp[1][j]=dp[0][j-1]+1;
else
dp[1][j]=max(dp[1][j-1],dp[0][j]);
}
}
printf("%d\n",t-dp[1][t]);
}
return 0;
}

  

最新文章

  1. 最详细易懂的CRC-16校验原理(附源程序)(转)
  2. HTML 最简单的tips 怎么支持指定DIV显示提示信息
  3. 不安装HALCON下安装运行版U盘加密狗驱动
  4. 根据Request获取客户端IP 内网IP及外网IP
  5. 【Android】Android Studio 进行代码混淆,打包release APK
  6. 这些情况下onReume不应该是你的选择
  7. Spring实战5:基于Spring构建Web应用
  8. 算法基础:最大递减数问题(Golang实现)
  9. python实现简单表单校验框架
  10. Linux下chkconfig命令详解(转)
  11. JS列表的下拉菜单组件(仿美化控件select)
  12. linux(centos7)下SVN服务器如何搭建
  13. Java &quot;==&quot; 和 &quot;equals&quot; 和 &quot;&quot; 问题
  14. (NO.00001)iOS游戏SpeedBoy Lite成形记(十一)
  15. 在Design界面直接拖放控件的时候,提示AS- This view is not constrained vertically. At runtime it will jump to the left/(0,0) unless you
  16. 基于vue-cli的eslint常用设置
  17. Linux 安装Jdk、mysql、apache、php、tomcat、nginx
  18. Z-tree 统计每一父节点的叶子节点数(看这一篇就够了)
  19. oracle表属性
  20. java中的类、对象、方法

热门文章

  1. 网站如何防Session冒名顶替和cookie防篡改
  2. express不是内部命令解决办法
  3. Zend Server安装后首次运行就出现Internal Server Error的解决
  4. Objective-C 实例方法可见度,方法
  5. 解决右滑返回手势和UIScrollView中的手势冲突
  6. ubuntu系统安装的MySql数据库,远程不能访问的几种可能问题
  7. 中级Perl 第三章课后习题
  8. html的input输入框提示信息 点击隐藏
  9. PHP框架_ThinkPHP数据库
  10. 页面点击关闭弹出提示js代码