A Plug for UNIX
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14862   Accepted: 5026

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 

Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was
built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs:
laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 

irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 

Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't
exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 

In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have
adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string
of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which
is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 

characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available.
Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4
A
B
C
D
5
laptop B
phone C
pager B
clock B
comb X
3
B X
X A
X D

Sample Output

1

Source

East Central North America 1999

题目大意:这题题目意思实在太难懂,只是题目意思搞清楚之后还是比較好做的

在这个题目里有两种物品,一个是插座,一个是电器插座仅仅有一个插孔和一

个插头,电器仅仅有一个插头首先有n种插座,n种插座用字符串表示,这n种插

座能够理解为是插在电源上的插座然后有m个电器。如今电器要充电,电器用

字符串表示,每一个电器都有自己能够插的插座(这个插座能够不是那n个插在电

源上的插座。能够是其它的插座)如今有k个信息s1 s2代表s1插座能够插到s2

插座上去,这里类似于将插头转换了一下这些s1与s2也能够不是那n个插在电

源上的插座给出这些个信息问你还有多少个电器没有插座能够用

建图:

建一个源点,指向全部电器。容量为1

全部电器指向他们能够插的那个插头上。容量为1

假设一个插头能够插到还有一个插头,那么将s1指向s2。容量为无限大

将全部插在电源上的插头指向汇点,容量为1





然后从源点到汇点求最大流就可以

只是建图会比較复杂,由于涉及到字符串的处理。所以用map容器比較好做点

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#include<map>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
#define M 1000
struct node{
int v,next,w;
}mp[M*M];
int head[M],dis[M],cnt,st,et;
void add(int u,int v,int w){
mp[cnt].v=v;
mp[cnt].w=w;
mp[cnt].next=head[u];
head[u]=cnt++;
mp[cnt].v=u;
mp[cnt].w=0;//有向图
mp[cnt].next=head[v];
head[v]=cnt++;
}
int bfs(){
memset(dis,-1,sizeof(dis));
queue<int> q;
while(!q.empty()) q.pop();
dis[st]=0;
q.push(st);
while(!q.empty()){
int u=q.front();
q.pop();
for(int i=head[u];i!=-1;i=mp[i].next){
int v=mp[i].v;
if(mp[i].w && dis[v]==-1){
dis[v]=dis[u]+1;
q.push(v);
if(v==et) return 1;
}
}
}
return 0;
}
int dinic(int u,int low){
if(u==et || low==0) return low;
int ans=low,i,a;
for(i=head[u];i!=-1;i=mp[i].next){
int v=mp[i].v;
if(dis[v]==dis[u]+1 && mp[i].w && (a=dinic(v,min(ans,mp[i].w)))){
mp[i].w-=a;
mp[i^1].w+=a;//開始的时候写成mp[i].v,,找了半天错。擦擦擦擦擦
ans-=a;
if(ans==0) return low;
}
}
return low-ans;
}
int main(){
int t,i,j,k,n,tot;
char str[30],ch[30];
scanf("%d",&n);
map<string,int> m;
cnt=0; tot=1;//给电器编号
memset(head,-1,sizeof(head));
m.clear();
st=0; et=M-1;//起点,终点
for(i=0;i<n;i++){
scanf("%s",str);
m[str]=tot++;
add(m[str],et,1);
} scanf("%d",&t);
for(i=0;i<t;i++){
scanf("%s %s",str,ch);
m[str]=tot++;
if(!m[ch]) m[ch]=tot++;
add(st,m[str],1);
add(m[str],m[ch],1);
}
scanf("%d",&k);
for(i=0;i<k;i++){
scanf("%s %s",str,ch);
if(!m[str]) m[str]=tot++;
if(!m[ch]) m[ch]=tot++;
add(m[str],m[ch],inf);
}
int ans=0;
while(bfs()){
ans+=dinic(st,inf);
}
printf("%d\n",t-ans);
return 0;
}

最新文章

  1. CPU中断和轮询
  2. Leetcode: Surrounded regions
  3. 获取google翻译的音频文件_合并音频文件的方法
  4. CentOS6.4 安装OpenResty和Redis 并在Nginx中利用lua简单读取Redis数据
  5. windows 10环境下 使用 msys2 + vs code 配置 c++ 的编译环境
  6. 实习小记-python中可哈希对象是个啥?what is hashable object in python?
  7. linux学习笔记2-命令总结2
  8. 【Valid Parentheses】cpp
  9. JS面向对象组件(四) -- 面向对象的继承
  10. C# 等待另外一个窗体关闭,再进行主线程的代码
  11. C#程序中访问配置文件
  12. C语言工具的简单辨析
  13. merge into Oracle里的 saveOrUapdate
  14. 54. Spiral Matrix(中等)
  15. Spark-Unit2-Spark交互式命令行与SparkWordCount
  16. [Java] Windows/Linux路径不同时,统一war的最简办法
  17. linux下udev
  18. HoloLens开发手记 - 语音输入 Voice input
  19. Centos的一个find命令配合rm删除某天前的文件
  20. linux:ls、ls -l、ls -al区别 示例

热门文章

  1. vim-YCM插件安装
  2. 英语音乐---三、Cry on my shoulder
  3. Windows10+VS2013+caffe+Python2.7+CUDA8.0 部署配置
  4. 设计url 通过分发的方式 Xadmin_demo
  5. spring boot 集成 mybatis,数据库为mysql
  6. java9新特性-15-全新的HTTP 客户端API
  7. CUDA笔记(九)
  8. PostgreSQL Replication之第八章 与pgbouncer一起工作(5)
  9. DedeCMS文章编辑不更新时间1970年1月1日
  10. Android布局之FrameLayout