Max Factor

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

Input

  • Line 1: A single integer, N

  • Lines 2..N+1: The serial numbers to be tested, one per line

Output

  • Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

Sample Input

4

36

38

40

42

Sample Output

38


解题心得:

  1. 就是一个简单的素数筛选,然后暴力找一下因子,判断记录就可以了。没有什么好说的。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 2e4+100;
bool pre_num[maxn]; //先吧素数给筛选出来
void get_pre_num()
{
for(int i=2; i<=sqrt(maxn); i++)
{
if(pre_num[i])
continue;
for(int j=i*i; j<maxn; j+=i)
pre_num[j] = true;
}
pre_num[1] = pre_num[0] = true;
} int main()
{
get_pre_num();
int n;
while(scanf("%d",&n) != EOF)
{
int Max = 0,pos = 1;
for(int i=0; i<n; i++)
{
int now;
scanf("%d",&now);
int N = now;
for(int j=2; j<=sqrt(now); j++)
{
if(now%j == 0)//暴力找因子
{
if(!pre_num[j])
{
if(j > Max)//记录一下就可以了
{
Max = j;
pos = N;
}
}
while(now%j == 0)
now /= j;
}
}
if(now > 1 && !pre_num[now])//别忘了最后还剩下一个
{
if(now > Max)
{
Max = now;
pos = N;
}
}
}
printf("%d\n",pos);
}
}

最新文章

  1. BZOJ1129 : [POI2008]Per
  2. web.xml的首页调用struts2的action解决方法
  3. P6 EPPM R16.1安装与配置指南(二)
  4. BZOJ3073 : [Pa2011]Journeys
  5. 学习练习 java面向对象封装汽车
  6. Hadoop学习笔记(1) ——菜鸟入门
  7. awesome awesomeness
  8. AppCanCSS背景图片的属性
  9. Security:蠕虫的行为特征描述和工作原理分析
  10. 用netstat查看网络状态详解
  11. jenkins 安装部署 springboot启动
  12. 开发手记:JedisConnectionException: Could not get a resource from the pool
  13. select2清除选择(选择框内的值)
  14. 11G新特性 -- variable size extents
  15. [UE4]UMG和关卡坐标变换、旋转小地图
  16. word_宏示例
  17. jquery实现图片上传前本地预览功能
  18. noip第34课作业
  19. 通过python将xml文件转换成html文件
  20. Caused by: android.content.res.Resources$NotFoundException: Resource ID #0x7f070058 android-studio 3.0 from canary 5 to canary 6

热门文章

  1. Win10 插入耳机后没有声音,拔出后电脑有声音
  2. CSS3 - CheakBox 开关效果
  3. Spark Mllib里的本地向量集(密集型数据集和稀疏型数据集概念、构成)(图文详解)
  4. BZOJ4939: [Ynoi2016]掉进兔子洞(莫队 bitset)
  5. Android篇---Styles和Themes常见用法可能疑点小结
  6. Java 反射机制(二)
  7. SQL Server AlwaysON从入门到进阶(6)——分析和部署AlwaysOn Availability Group
  8. Python+selenium整合自动发邮件功能
  9. SqlServer中嵌套事务使用--事务计数指示 BEGIN 和 COMMIT 语句的数目不匹配 --根本问题
  10. 洛谷 P2827 蚯蚓