Surprising Strings
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5783   Accepted: 3792

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible
distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG
is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

Source

解题思路:

推断一个字符串是不是surpring。

条件:该字符串的全部D-pairs,D是字符串中两个字母的距离, 假设全部的D-pairs都不同,那么该字符串是D-unique。

假设对全部的距离D,都满足D-unique,那么字符串就是surpring.

比方ZGBG

0-pairs :  ZG  GB BG  不同样,是0-unique

1-pairs :  ZB  GG        不同样,是1-unique

2-pairs:   ZG               不同样。是2-unique

综上。ZGBG是surpring

每个D-pairs进行推断。假设在推断一个D-pairs过程中有同样的,那么该字符串肯定不是surpring。

用map<string,bool> 来推断是否字符串已经出现过。要注意其声明的位置,要在每一层D循环里面声明。

代码:

#include <iostream>
#include <stdio.h>
#include <map>
#include <string.h>
using namespace std;
char str[80]; int main()
{
while(scanf("%s",str)!=EOF&&str[0]!='*')
{
int len=strlen(str);
if(len<=2)
{
cout<<str<<" is surprising."<<endl;
continue;
}
bool ok=1;//是surpring
for(int d=0;d<=len-2;d++)//距离d
{
bool dtap=1;//是D-unique
map<string,bool>mp;//注意其声明的位置
for(int s=0;s<=len-2&&s+d+1<len;s++)
{
string temp="";
temp+=str[s];
temp+=str[s+d+1];
if(mp[temp])//该字符串出现过
{
dtap=0;
break;
}
else
mp[temp]=1;
}
if(!dtap)
{
ok=0;
break;
}
}
if(ok)
cout<<str<<" is surprising."<<endl;
else
cout<<str<<" is NOT surprising."<<endl;
}
return 0;
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。

最新文章

  1. 微信小程序
  2. centos系统编译安装nginx+php环境另加独立mysql教程
  3. 分枝定界的matlab实现
  4. jbpm的学习 出处http://blog.csdn.net/hxirui/article/details/1221911
  5. Spark集群 + Akka + Kafka + Scala 开发(1) : 配置开发环境
  6. C#跨线程操作控件
  7. C#编写的通过汉字得到拼音和五笔码
  8. win7电脑共享VPN连接教程
  9. 使用ssh免密码登录其他机器
  10. windows 中配置 nodejs npm
  11. C# select的联动效果
  12. 原型模式和基于原型继承的js对象系统
  13. Spring Boot Actutaur + Telegraf + InFluxDB + Grafana 构建监控平台
  14. linux下中文乱码问题解决
  15. neo1973 audio subsystem
  16. 使用jsonp请求本地json文件
  17. CRM INBOX 结果增强功能
  18. C++Primer第五版——习题答案详解(十)
  19. DirectX之顶点法线的计算
  20. bzoj 4709 [Jsoi2011]柠檬——单调栈二分处理决策单调性

热门文章

  1. (二)SSO之CAS框架单点退出,自己定义退出界面.
  2. 安装hadoop1.2.1集群环境 分类: A1_HADOOP 2014-08-29 15:49 1444人阅读 评论(0) 收藏
  3. Delphi 获取Internet缓存文件 -- FindFirstUrlCacheEntry FindNextUrlCacheEntry
  4. GoJS超详细入门(插件使用无非:引包、初始化、配参数(json)、引数据(json)四步)
  5. ssl 内存泄露
  6. 【u006】海战
  7. SpringMVC中支持多视图解析
  8. [Flow] Declare types for application
  9. ios获取iphone手机设备型号
  10. Java Web 实用返回结果封装