样例输入:
THE QUICK BROWN FOX JUMPED OVER THE LAZY DOG.
THIS IS AN EXAMPLE TO TEST FOR YOUR
HISTOGRAM PROGRAM.
HELLO! 
样例输出:

*

*

*                   *

*                   *     *   *

*                   *     *   *

*       *     *             *     *   *

*       *     * *     * *   *     * * *

*       *   * * *     * *   * *   * * * *

*     * * * * * *     * * * * *   * * * *     * *

* * * * * * * * * * * * * * * * * * * * * * * * * *

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

题目的意思是从命令行输入一个大写的字符串,求一个字符出现的频率,画出来。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays; public class Main { public static void main(String[] args) throws NumberFormatException,
IOException {
BufferedReader read = new BufferedReader(new InputStreamReader(
System.in));
int[] a = new int[26];
int tt;
for (int i = 0; i < 4; i++) {
String str = read.readLine();
for (int j = 0; j < str.length(); j++) {
tt = str.charAt(j) - 'A';
if (tt >= 0 && tt <= 25) {
a[tt]++;
}
}
}
int max = 0;
for (int i = 0; i < 26; i++) {
if (a[i] > max) {
max = a[i];
}
}
char[][] c = new char[max + 1][51];
for (int i = 0; i < max + 1; i++) {
Arrays.fill(c[i], ' ');
}
for (int i = 0; i < 26; i++) {
int h = a[i];
for (int j = 0; j < h; j++) {
c[max - 1 - j][i * 2] = '*';
}
}
for (int i = 0; i < 26; i++) {
c[max][i * 2] = (char) ('A' + i);
}
for (int i = 0; i < max + 1; i++) {
String str = String.valueOf(c[i]);
while (str.endsWith(" ")) {
str = str.substring(0, str.length() - 1);
}
System.out.println(str);
}
}

最新文章

  1. Promise和$.Deferred总结
  2. WPF中设置快捷键
  3. 可能 delphi7 下稳定的最后一版本 GDIPLUS
  4. thinkphp禁止模版标签解析
  5. C++学习3
  6. 第一部分 CLR基础:第2章 生成、打包、部署和管理应用程序及类型
  7. [Everyday Mathematics]20150114
  8. 白书P60 - 硬币问题
  9. extjs中gridpanel动态显示/隐藏列
  10. CSS 常用自定义样式
  11. Laravel创建Model
  12. bis.org
  13. tcp那个孤独的小包到底怎么回事?
  14. KMeans算法分析以及实现
  15. [朴孝敏][Ooh La La]
  16. Git分支管理的策略梳理
  17. eclipse签名使用的key文件(android生成keystore)
  18. Springbooot +Mybaties 配置数据库多数据源
  19. BBS-基于forms组件和ajax实现注册功能
  20. Vue.Draggable:基于 Sortable.js 的 Vue 拖拽组件使用中遇到的问题

热门文章

  1. HTML表单的应用
  2. Python 爬虫知识点 - 淘宝商品检索结果抓包分析(续一)
  3. socket网络编程【python】
  4. Java fluent风格
  5. iOS 数据类型转换
  6. Extjs6.2.0搭建项目框架
  7. 【MySQL】查询时强制区分大小写的方法
  8. android基础----&gt;音频和视频的使用
  9. 【Android】保存Bitmap到SD卡
  10. 把 Activity 改成 ListActivity继续使用 setContentView