The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3
此题纠结了好久,重点是想办法输出,把所有更新了的节点记录,到下一次更新时输出
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
const double inf=1e20;
double d[800],cost[800][800];
int x[800],y[800];
int n,m;
struct node{
   double x,y;
}e[800];
double dis(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
void prim()
{
    bool vis[800];
    for(int i=1;i<=n;i++)
    {
        vis[i]=0;
        d[i]=inf;
    }
    d[0]=0;
    int num=0;
    while(1){
        int v=-1;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i]&&(v==-1||d[i]<d[v]))//找到最小的边
                v=i;
        }
        if(v==-1)break;//无更新退出
        vis[v]=1;
        if(num&&cost[x[v]][y[v]])printf("%d %d\n",x[v],y[v]);
        num=1;
        for(int i=1;i<=n;i++)
        {
            if(d[i]>cost[i][v])//把所有的边都更新一边
            {
                d[i]=cost[i][v];
                x[i]=i;
                y[i]=v;
          /* if(cost[i][v]!=0)
printf("%d %d\n",i,v);//每次更新全部时,即使不是下一个节点,也是会被更新的,所以要只输出下一个节点的*/
            }
        }
    }
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%lf%lf",&e[i].x,&e[i].y);
    for(int i=1;i<=n;i++)
    {
        for(int j=i+1;j<=n;j++)
        {
            cost[i][j]=cost[j][i]=dis(e[i],e[j]);
        }
        cost[i][i]=0;
    }
    scanf("%d",&m);
    for(int i=1;i<=m;i++)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        cost[a][b]=cost[b][a]=0;
    }
    prim();
    return 0;
}

最新文章

  1. 学习web前端前感
  2. (高精度运算4.7.26)POJ 1220 NUMBER BASE CONVERSION(高精度数的任意进制的转换——方法:ba1-----&gt;10进制-----&gt;ba2)
  3. HW3.28
  4. C# 各版本更新简介
  5. 【C#】.NET中设置代理服务器浏览网页的实现--转载
  6. BZOJ 1631: [Usaco2007 Feb]Cow Party( 最短路 )
  7. HDU 4831 Scenic Popularity (段树)
  8. 依赖倒置原则DIP(面向接口编程—OOD)
  9. 修改NavigationBar样式
  10. URI和URL差别以及相对路径和绝对路径的差别
  11. jmeter中的函数
  12. Hbaseflush处理流程
  13. Python开发【模块】:tornado.queues协程的队列
  14. Google Protocol Buffers 入门
  15. VS与Opencv的亲密接触之安装配置过程
  16. Spring Cloud Dalston.SR5 BUG一记
  17. autolayout不work
  18. AE和Mocha结合做视频后期制作
  19. maven仓库介绍 牛人博客
  20. 【LeetCode】Validate Binary Search Tree 二叉查找树的推断

热门文章

  1. 2017Java技术预备作业1501黄学超
  2. struct和typedef struct在c++中的用法
  3. Python中三种基本结构的语句
  4. (27)IO流小结
  5. 交叉编译Python-2.7.13到ARM(aarch32)—— 支持sqlite3
  6. Beautils工具类实现的原理
  7. Azure Messaging-ServiceBus Messaging消息队列技术系列6-消息回执
  8. 海量数据集利用Minhash寻找相似的集合【推荐优化】
  9. Fireworks快捷键大全和ps查看切图的坐标颜色
  10. 常见排序算法-Python实现