Problem Description
Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

 
Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

 
Output
Each output line should contain an integer number. No other characters should appear in the output.

 
Sample Input
6
10
12
0
 
Sample Output
1
2
1
#include<iostream>
#include<cmath>
using namespace std;
int prime[800000];
int isprime(int a)//判断是否是素数
{
int i;
for (i=2;i<=sqrt(a*1.0)+0.5;i++)
if(a%i==0)
return 0;
return 1;
}
void prime_b()//打素数表
{
int i;
for(i=2;i<=32768;i++)
if(isprime(i))//i是素数记为1
prime[i]=1;
else //不是记为0
prime[i]=0;
}
int main()
{
int n,p,k; prime_b(); while(cin>>n&&n)
{
k=0;
if(prime[n-2])//和2组和的数
k++;
for(p=3;p<=n/2;p+=2)
if(prime[p]&&prime[n-p])
k++;
cout<<k<<endl;
}
}

最新文章

  1. DataSnap 2009 系列之三 (生命周期篇)
  2. UILabel添加图片之富文本的简单应用
  3. 2015年10月TIOBE编程语言排行榜
  4. oninput,onpropertychange,onchange的使用方法和差别
  5. hiho 分冶专题
  6. Call U
  7. Struts的前世今身
  8. Asp.net MVC Razor常见问题及解决方法
  9. CI 结合 vue.js 的搜索功能模块
  10. Head First 设计模式 第5章 单例模式
  11. bzoj 4538: [Hnoi2016]网络
  12. Linux定时及mysql远程
  13. 2013年省赛H题
  14. ALM 中查看某个 test 的更改 history 历史
  15. oracle expdp自动备份脚本
  16. word2vec:将bin转换为txt
  17. python第三十七天--异常--socket
  18. P3806 【模板】点分治1(CDQ分治)
  19. apiCloud 双击事件
  20. Java基础——Servlet(三)

热门文章

  1. 84. 从视图索引说Notes数据库(下)
  2. 【Java】【Fulme】Flume-NG源代码阅读之SpoolDirectorySource
  3. js中赋值表达式的值为右边
  4. Nlog的简单使用
  5. 进度记录 和 安装imagick时Cannot locate header file MagickWand.h错误的解决
  6. hdu 1242 Rescue(bfs)
  7. POJ3264——Balanced Lineup(线段树)
  8. Java面试题之一
  9. iOS Responder Chain 响应者链
  10. uVa 714 (二分法)