When participating in programming contests, you sometimes face the following problem: You know how to calcutale the output for the given input values, but your algorithm is way too slow to ever pass the time limit. However hard you try, you just can’t discover the proper break-off conditions that would bring down the number of iterations to within acceptable limits. Now if the range of input values is not too big, there is a way out of this. Let your PC rattle for half an hour and produce a table of answers for all possible input values, encode this table into a program, submit it to the judge, et voila: Accepted in 0.000 seconds! (Some would argue that this is cheating, but remember: In love and programming contests everything is permitted). Faced with this problem during one programming contest, Jimmy decided to apply such a ’technique’. But however hard he tried, he wasn’t able to squeeze all his pre-calculated values into a program small enough to pass the judge. The situation looked hopeless, until he discovered the following property regarding the answers: the answers where calculated from two integers, but whenever the two input values had a common factor, the answer could be easily derived from the answer for which the input values were divided by that factor. To put it in other words:
Say Jimmy had to calculate a function Answer(x,y) where x and y are both integers in the range [1,N]. When he knows Answer(x,y), he can easily derive Answer(k∗x,k∗y), where k is any integer from it by applying some simple calculations involving Answer(x,y) and k. For example if N = 4, he only needs to know the answers for 11 out of the 16 possible input value combinations: Answer(1,1), Answer(1,2), Answer(2,1), Answer(1,3), Answer(2,3), Answer(3,2), Answer(3,1), Answer(1,4), Answer(3,4), Answer(4,3) and Answer(4,1). The other 5 can be derived from them (Answer(2,2), Answer(3,3) and Answer(4,4) from Answer(1,1), Answer(2,4) from Answer(1,2), and Answer(4,2) from Answer(2,1)). Note that the function Answer is not symmetric, so Answer(3,2) can not be derived from Answer(2,3).
Now what we want you to do is: for any values of N from 1 upto and including 50000, give the number of function Jimmy has to pre-calculate.

Input
The input file contains at most 600 lines of inputs. Each line contains an integer less than 50001 which indicates the value of N. Input is terminated by a line which contains a zero. This line should not be processed.

Output
For each line of input produce one line of output. This line contains an integer which indicates how many values Jimmy has to pre-calculate for a certain value of N.

Sample Input
2

5

0

Sample Output

3

19

这道题很简单,,,,,一开始推就发现是在求互质数目*2。直接欧拉函数打表ok

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#define N 1000010
#define maxn 50010
using namespace std;
bool vis[N];
int val[N];
int prime[N];
long long p[N];
int pn=0;
void gp()
{
for (int i = 2; i < N; i++) {
if (vis[i]) continue;
prime[pn++] = i;
val[i]=1;
for (int j = i; j < N; j += i)
vis[j]=1;
}
}
int main()
{
//freopen("datain.txt","r",stdin);
//freopen("dataout.txt","w",stdout);
p[1]=1;
//gp();
int i,j;
for(i=1; i<=maxn; i++)
p[i]=i;
for(i=2; i<=maxn; i+=2)
p[i]/=2;
for(i=3; i<=maxn; i+=2)
if(p[i]==i)
{
for(j=i; j<=maxn; j+=i)
p[j]=p[j]/i*(i-1);
}
for(int i=2;i<maxn;i++)
{
p[i]=p[i-1]+2*p[i];
}
int m,n;
while(~scanf("%d",&n),n)
{
cout<<p[n]<<endl;
}
}

  

最新文章

  1. IOS 杂笔-14(被人遗忘的owner)
  2. jsf组件对应表
  3. AS配置IDE
  4. Jenkins 安装
  5. DRY原则
  6. 【hadoop2.6.0】安装+例子运行
  7. 【WebForm】Js调用后台C#方法
  8. loadrunner SQL2008
  9. linux学习之八---Linux进程基础知识
  10. try catch 学习记入
  11. Spring 的优秀工具类盘点第 2 部分
  12. Codeforces 494D Upgrading Array
  13. &lt;Win32_17&gt;集音频和视频播放功能于一身的简易播放器
  14. TimeDelta.total_seconds() in Python2.6-
  15. Swift3 GCD队列优先级说明
  16. apache在window server 2003下的安全配置
  17. [总结] 第二类Stirling数
  18. 孟岩:怎么看待Coin与Token的关系?
  19. linux(manjaro)磁盘迁移/opt /home
  20. WPF Chart

热门文章

  1. MATLAB线性回归方程与非线性回归方程的相关计算
  2. phpstorm 10 注册码
  3. 错误提示”void is an invalid type for the variable“
  4. iOS-swift-枚举和结构体
  5. 在基于WCF开发的Web Service导出WSDL定义问题及自定义wsdl:port 名称
  6. 你真的了解 advice, joinpoint,pointcut,aspect吗?
  7. javascript中如何实现继承
  8. DEEP LEARNING 大满贯课程表
  9. 关于Linux主流框架运维工作剖析
  10. ubuntu linux 使用命令行安装 google chrome