Matrix
   

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).



We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.



1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).

2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.



The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].



There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1  
# include<iostream>
# include<cstdio>
# include<cstring>
# include<string>
# include<set>
# include<map>
# include<sstream>
using namespace std;
const int maxn=1000+5;
int tree[maxn][maxn];
char a[10];
int n;
int lowbit(int x)
{
return x&-x;
}
int getsum(int x,int y)
{
int s=0;
for(int i=x;i>0;i-=lowbit(i))
for(int j=y;j>0;j-=lowbit(j))
s+=tree[i][j];
if(s%2==0) return 0;
else
return 1;
}
void update(int x,int y)
{
for(int i=x;i<=n;i+=lowbit(i))
for(int j=y;j<=n;j+=lowbit(j))
tree[i][j]^=1;
}
int main()
{
/*#ifndef ONLINE_JUDGE
freopen("in.cpp","r",stdin);
freopen("out.cpp","w",stdout);
#endif*/
int t;
scanf("%d",&t);
while(t--)
{
int m;
scanf("%d%d",&n,&m);
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
tree[i][j]=0;
while(m--)
{
int x1,y1,x2,y2;
scanf("%s%d%d",&a[0],&x1,&y1);
if(a[0]=='C')
{
scanf("%d%d",&x2,&y2);
update(x2+1,y2+1);
update(x2+1,y1);
update(x1,y2+1);
update(x1,y1);
}
else if(a[0]=='Q')
{
printf("%d\n",getsum(x1,y1));
}
}
cout<<endl;
} return 0;
}

最新文章

  1. Spring 的动态数据源实现
  2. CSS中不为人知Zoom属性的使用介绍(IE私有属性)
  3. makefile 笔记
  4. 打包ipa出现问题记录
  5. Java 菜鸟学习之 script脚本语句
  6. 各浏览器对typeof运算符的实现差异
  7. Django之Model(一)--基础篇
  8. VSim [a Racing-simulator by Vell001]
  9. Java基础—异常处理总结
  10. mysql视图的作用(详细)
  11. A. Brain&#39;s Photos ——Codeforces Round #368 (Div. 2)
  12. CSS小技巧-两个盒子之间的间距问题
  13. 解决在Ubuntu系统下用matplotlib作图时出现中文乱码问题
  14. open live writer 测试
  15. win10优化开机进程
  16. 论文阅读笔记二十八:You Only Look Once: Unified,Real-Time Object Detection(YOLO v1 CVPR2015)
  17. [转]:Delphi XE中泛型数组的使用范例
  18. [MapReduce_add_5] MapReduce 实现标签的生成与聚合
  19. TP5一对一、一对多关联模型的使用
  20. 【xsy1061】排列 树状数组

热门文章

  1. HttpGet协议与正则表达
  2. oracle 通过查询灵活插入数据 insert into ...select..
  3. 使用jQuery实现tag便签去重效果
  4. IOS获取来电去电来电归属系统通知达到效果(一)
  5. https原理及tomcat配置https方法
  6. poj3667(线段树)
  7. ThinkPHP中的volist标签中使用eq标签出错
  8. Socket编程实践(12) --UDP编程基础
  9. 提高SQL执行效率
  10. 模拟Post