Rails 

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible
to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.



 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has coaches
numbered in increasing order . The chief for train reorganizations must know whether it is possible to marshal coaches continuing
in the direction B so that their order will be . Help him and write a program that decides whether it is possible to
get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there
can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described
above. In each of the next lines of the block there is a permutation of The
last line of the block contains just 0.

The last block consists of just one line containing 0.

Output

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if
it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after
the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No Yes

有n辆火车  按1到n的顺序进站  最后进站的车能够在不论什么时候出去  推断给定的出站序列是否可能

火车仅仅有两种状态  从A进站  或者从站到B   模拟栈的操作即可了

令A表示A中当前待进站的第一辆火车  tar[B]表示出站序列中当前应该出站的火车   sta为火车站

当A==tar[B]的时候  A进站立即出战   否则当站中最后一辆==tar[B]时   这辆车出站  都不满足就仅仅能A中的最前面的火车进站

当n辆火车所有进站  而站中还有火车是   给定的出战序列就是不可能的

#include<cstdio>
#include<stack>
using namespace std;
const int N = 1005;
int n, tar[N], A, B;
int main()
{
while (scanf ("%d", &n), n)
{
while (scanf ("%d", &tar[1]), tar[1])
{
for (int i = 2; i <= n; ++i)
scanf ("%d", &tar[i]);
stack<int> sta;
A = B = 1;
bool ok = true;
while (B <= n)
{
if (A == tar[B])
{ ++A; ++B; }
else if (!sta.empty() && sta.top() == tar[B])
{ sta.pop(); ++B; }
else if (A <= n)
sta.push (A++);
else
{ ok = false; break; }
}
printf (ok ? "Yes\n" : "No\n");
}
printf("\n");
}
return 0;
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。

最新文章

  1. 整理常用加密 iOS 与 Android 加密 MD5-SHA1
  2. ArcGIS API中FindTask中文搜索无效,服务器编码问题URIEncoding=&quot;utf-8&quot;
  3. android自定义控件(6)-详解在onMeasure()方法中如何测量一个控件尺寸
  4. Oracle 分区表的新增、修改、删除、合并。普通表转分区表方法
  5. Mysql的存储过程(以Mysql为例进行讲解)
  6. 【sgu282】Isomorphism
  7. WebDriver运行异常列表
  8. JavaScript学习总结【11】、JS 运动
  9. Django学习(三) Django模型创建以及操作
  10. MongoDB--MapReduce分布统计s
  11. nvarchar 和varchar区别
  12. Java爬虫——B站弹幕爬取
  13. .htaccess 文件来进行用户组的目录权限访问控制
  14. python 数字以及字符串(方法总结,有的可能理解错误)
  15. ZJOI2019二试游记
  16. mysql group_concat用法
  17. Axure 第一个原型 简单的登录页面
  18. [bug]不包含“AsNoTracking”的定义
  19. [android] 看博客学习Android常见的几种RuntimeException
  20. springmvc.xml 上传文件的配置

热门文章

  1. OpenCV-Python教程(5、初级滤波内容)
  2. Python什么是二次开发的意义?python在.net项目采用
  3. LVS+Keepalived实现高可用负载均衡(转)
  4. pygame在安装过程中无法找到videodev.h错误
  5. Unity3D发布WebPlayer时Failed to download data file解决方案
  6. 基于.net开发chrome核心浏览器【四】
  7. 原创教程“ActionScript3.0游戏中的图像编程”開始连载啦!
  8. Windows Phone开发(17):URI映射
  9. Python编程预约参观北京行动纲要
  10. Windows+Atlassian-Jira-6.0.4+MySql5.0安装破解汉化