It has been said that a watch that is stopped keeps better time than one that loses 1 second per day.

The one that is stopped reads the correct time twice a day while the one that loses 1 second per day is correct only once every 43,200 days.

This maxim applies to old fashioned 12-hour analog watches, whose hands move continuously (most digital watches would display nothing at all if stopped).

Given two such analog watches, both synchronized to midnight, that keep time at a constant rate but run slow by k and m seconds per day respectively, what time will the watches show when next they have exactly the same time?

Input

Input consists of a number of lines, each with two distinct non-negative integers k and m between 0 and 256, indicating the number of seconds per day that each watch loses.

Output

For each line of input, print k, m, and the time displayed on each watch, rounded to the nearest minute. Valid times range from 01:00 to 12:59.

Sample Input

1 2

0 7

Sample Output

1 2 12:00

0 7 10:17

题意 两个表一个表一天慢k秒,另一个表一天慢m秒,问下一次相同的时间是多少

表的一圈是43200秒,一天是86400秒

追及问题 经过43200/m-k天再次时间一样

此时 表走了( 43200/m-k )*( 86400-k )秒

AC代码

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <queue>
#include <vector>
#include <algorithm>
#define maxn 100010
using namespace std;
typedef long long ll;
int main()
{
int k,m;
int min,h;
while(scanf("%d%d",&k,&m)!=EOF)
{
int a=abs(m-k);
ll s=(ll)(43200.0/a*(86400.0-k));
s%=; //这些天转了s/43200圈后剩余的秒数
int min=s/; //求出分钟数
s%=; //rounded to the nearest minute
if(s>=)
min++;
int h=min/; //求出小时数
min%=; // 分的时间
h%=; // 没有0点换成12点
if(h==)
h=;
printf("%d %d %02d:%02d\n", k, m, h, min);//格式输出
}
}

最新文章

  1. ES6 学习笔记(1)
  2. JVM基本原理
  3. Android成长日记日记-Debug调试程序
  4. Android的ADB配置环境和adb指令使用
  5. 【CodeForces 297C】Splitting the Uniqueness
  6. redmine后台运行命令
  7. java.lang.NoSuchFieldError: VERSION_2_3_0 报错解决方案
  8. C# —— IList, ArrayList与List的区别详解
  9. Houdini 13在Ubuntu系统下流畅运行、不崩溃
  10. .NET中开源CMS目录
  11. extend vg(pv,lv)use HotPlug Storage PV for VMI(ECC Env)
  12. CGroup 介绍、应用实例及原理描述
  13. Linux - 简明Shell编程13 - 用户输入(UserInput)
  14. JWT 在前后端分离中的应用与实践
  15. Linux下ps -ef和ps aux的区别
  16. eclipse spring-boot-mybatis 的记录
  17. Nginx是什么?Nginx介绍及Nginx的优点
  18. C# Note30: 网络爬虫
  19. python用ftplib上传下载中文报错解决
  20. Python函数学习——初步认识

热门文章

  1. C++ 知识点总结复习
  2. 【Zookeeper】源码分析之服务器(三)之LeaderZooKeeperServer
  3. JS画图之七【时钟】
  4. 阿里云ECS升级OpenSSL记录
  5. Mac下nvm管理node.js版本问题
  6. 02.将SDK获取到的ECS主机信息入库
  7. Mac说——关闭SIP
  8. C# winForm资源文件实现多语言切换
  9. MySQL 数据类型和约束(外键是重点&#128580;)
  10. Windows上Python2与Python3共存