洛谷 P3106 [USACO14OPEN]GPS的决斗Dueling GPS's

洛谷传送门

JDOJ 2424: USACO 2014 Open Silver 2.Dueling GPSs

JDOJ传送门

Description

Problem 2: Dueling GPS's [Brian Dean, 2014]

Farmer John has recently purchased a new car online, but in his haste he

accidentally clicked the "Submit" button twice when selecting extra

features for the car, and as a result the car ended up equipped with two

GPS navigation systems! Even worse, the two systems often make conflicting

decisions about the route that FJ should take.

The map of the region in which FJ lives consists of N intersections

(2 <= N <= 10,000) and M directional roads (1 <= M <= 50,000). Road i

connects intersections A_i (1 <= A_i <= N) and B_i (1 <= B_i <= N).

Multiple roads could connect the same pair of intersections, and a

bi-directional road (one permitting two-way travel) is represented by two

separate directional roads in opposite orientations. FJ's house is located

at intersection 1, and his farm is located at intersection N. It is

possible to reach the farm from his house by traveling along a series of

directional roads.

Both GPS units are using the same underlying map as described above;

however, they have different notions for the travel time along each road.

Road i takes P_i units of time to traverse according to the first GPS unit,

and Q_i units of time to traverse according to the second unit (each

travel time is an integer in the range 1..100,000).

FJ wants to travel from his house to the farm. However, each GPS unit

complains loudly any time FJ follows a road (say, from intersection X to

intersection Y) that the GPS unit believes not to be part of a shortest

route from X to the farm (it is even possible that both GPS units can

complain, if FJ takes a road that neither unit likes).

Please help FJ determine the minimum possible number of total complaints he

can receive if he chooses his route appropriately. If both GPS units

complain when FJ follows a road, this counts as +2 towards the total.

Input

* Line 1: The integers N and M.

Line i describes road i with four integers: A_i B_i P_i Q_i.

Output

* Line 1: The minimum total number of complaints FJ can receive if he

routes himself from his house to the farm optimally.

Sample Input

5 7 3 4 7 1 1 3 2 20 1 4 17 18 4 5 25 3 1 2 10 1 3 5 4 14 2 4 6 5

Sample Output

1

HINT

INPUT DETAILS:

There are 5 intersections and 7 directional roads. The first road connects

from intersection 3 to intersection 4; the first GPS thinks this road takes

7 units of time to traverse, and the second GPS thinks it takes 1 unit of

time, etc.

OUTPUT DETAILS:

If FJ follows the path 1 -> 2 -> 4 -> 5, then the first GPS complains on

the 1 -> 2 road (it would prefer the 1 -> 3 road instead). However, for

the rest of the route 2 -> 4 -> 5, both GPSs are happy, since this is a

shortest route from 2 to 5 according to each GPS.

题目大意:

给你一个N个点的有向图,可能有重边.

有两个GPS定位系统,分别认为经过边i的时间为Pi,和Qi.

每走一条边的时候,如果一个系统认为走的这条边不是它认为的最短路,就会受到警告一次T T

两个系统是分开警告的,就是说当走的这条边都不在两个系统认为的最短路范围内,就会受到2次警告.

如果边(u,v)不在u到n的最短路径上,这条边就受到一次警告,求从1到n最少受到多少次警告。

题解:

3遍SPFA 打到我吐血。

我不想讲了。

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
#define inf 0x3f3f3f
using namespace std;
struct edge{
int w,to,next;
}e1[201100];
edge e2[201100];
edge e3[201100];
int head1[101100],head2[101100],head3[101100];
int d1[101100],d2[101100],d3[101100];
int f1[101100],f2[101100];
int n,en1,en2,en3,m;
void add1(int v,int u,int w){
en1++;
e1[en1].to=v;
e1[en1].w=w;
e1[en1].next=head1[u];
head1[u]=en1;
}
void add2(int v,int u,int w){
en2++;
e2[en2].to=v;
e2[en2].w=w;
e2[en2].next=head2[u];
head2[u]=en2;
}
void add3(int u,int v,int w){
en3++;
e3[en3].to=v;
e3[en3].w=w;
e3[en3].next=head3[u];
head3[u]=en3;
}
void sp1(int s){
queue<int> q;
int inq[20010];
memset(inq,0,sizeof(inq));
for(int i=1;i<=n;i++)d1[i]=inf;
q.push(s);inq[s]=1;d1[s]=0;
while(!q.empty()){
int u=q.front();q.pop();inq[u]=0;
for(int i=head1[u];i;i=e1[i].next){
int v=e1[i].to,w=e1[i].w;
if(d1[v]>d1[u]+w)
{
d1[v]=d1[u]+w;
f1[v]=i;
if(!inq[v]){
inq[v]=1;
q.push(v);
}
}
}
}
}
void sp2(int s){
queue<int> q;
int inq[20010];
memset(inq,0,sizeof(inq));
for(int i=1;i<=n;i++)d2[i]=inf;
q.push(s);inq[s]=1;d2[s]=0;
while(!q.empty()){
int u=q.front();q.pop();inq[u]=0;
for(int i=head2[u];i;i=e2[i].next){
int v=e2[i].to,w=e2[i].w;
if(d2[v]>d2[u]+w)
{
d2[v]=d2[u]+w;
f2[v]=i;
if(!inq[v]){
inq[v]=1;
q.push(v);
}
}
}
}
}
void sp3(int s){
queue<int> q;
int inq[20010];
memset(inq,0,sizeof(inq));
for(int i=1;i<=n;i++)d3[i]=inf;
q.push(s);inq[s]=1;d3[s]=0;
while(!q.empty()){
int u=q.front();q.pop();
for(int i=head3[u];i;i=e3[i].next){
int v=e3[i].to,w=e3[i].w;
if(i==f1[u])w--;
if(i==f2[u])w--;
if(d3[v]>d3[u]+w)
{
d3[v]=d3[u]+w;
if(!inq[v]){
inq[v]=1;
q.push(v);
}
}
}inq[u]=0;
}
}
int main(){
cin>>n>>m;
for(int i=1;i<=m;i++){
int a,b,c,d;
cin>>a>>b>>c>>d;
add1(a,b,c);
add2(a,b,d);
add3(a,b,2);
}
sp1(n);
sp2(n);
sp3(1);
cout<<d3[n];
}

最新文章

  1. 使用C#代码部署SharePoint 2013开发包简单总结(一)
  2. 拿到腾讯实习offer的前后小事
  3. 51nod1057(python2计算n!)
  4. Nginx服务器
  5. jQuery习题的一些总结
  6. spring-aop示例
  7. Shadow Mapping 的原理与实践(二)
  8. mcrypt加密与解密
  9. HAOI2007反素数
  10. java编程小技巧
  11. 深度学习word2vec笔记之应用篇
  12. Pyhton编程(一)之第一个Pyhton程序
  13. user-agent | what is the &quot;user-agent&quot; ?
  14. 001.[python学习]写在前面的
  15. WPF 如何创建自己的WPF自定义控件库
  16. java----String解析
  17. 使用IntelliJ IDEA和Eclipse导入Github项目
  18. 时间序列分析 异常分析 stl
  19. linux命令--文件查询
  20. 利用净现值(NPV)分析对比方案的可行性

热门文章

  1. 44 dlib鼠标指定目标跟踪
  2. CF-1155 D.Beautiful Array
  3. SSM配置动态数据源
  4. 公式推导【IoUNet//ECCV2018】
  5. 性能对比:aelf智能合约运行环境性能是evm的1000倍
  6. Linux高性能服务器编程,书中的 shell 命令
  7. Could not find resource——mybatis 找不到映射器xml文件
  8. js数组试列题
  9. Java自学-集合框架 二叉树
  10. JS打开url的几种方法