传送门

Classes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.

Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.

Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in
course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.

However, due to statistical errors, some data are wrong and these data should be ignored.

Smart you must know how to write a program to find the maximum number of students.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.

Each case begins with one line with one integer N, indicates the number of class.

Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class. 

It's guaranteed that at least one data is right in each test case.

Limits
T≤100
1≤N≤100
0≤a,b,c,d,e,f,g≤100
 

Output
For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.
 

Sample Input

2
2
4 5 4 4 3 2 2
5 3 1 2 0 0 0
2
0 4 10 2 3 4 9
6 12 6 3 5 3 2
 

Sample Output

7
15

Hint

In the second test case, the data uploaded by Class 1 is wrong.
Because we can't find a solution which satisfies the limitation.
As for Class 2, we can calculate the number of students who only enrolled in course A is 2,
the number of students who only enrolled in course B is 6, and nobody enrolled in course C,
the number of students who only enrolled in courses A and B is 1,
the number of students who only enrolled in courses B and C is 3,
the number of students who only enrolled in courses A and C is 1,
the number of students who enrolled in all courses is 2,
so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.

 

Statistic | Submit | Clarifications | Back

代码如下

#include <iostream>
#include <string>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
#define ll long long
int main()
{
int a, b, c, ab, bc, ac, abc;
int t,n,ans=0;
cin >> t;
while (t--) {
ans = 0;
cin >> n;
for (int i = 0; i < n;++i) {
int cnt = 0;
cin >> a >> b >> c >> ab >> bc >> ac >> abc;
ac =ac-abc;
bc =bc-abc;
ab =ab-abc;
if (ab < 0 || bc < 0 || ac < 0)
continue;
a = a - ab - ac - abc;
b = b - ab - bc - abc;
c = c - ac - bc - abc;
if (a < 0 || b < 0 || c < 0)
continue;
cnt += a + b + c + ab + ac + bc + abc;
ans = max(ans, cnt);
}
cout << ans << endl;
}
return 0;
}

最新文章

  1. shell脚本规划化模板
  2. [译] jQuery 3 有哪些新东西
  3. 深入理解 Win32 PE 文件格式
  4. CSS魔法堂:Position定位详解
  5. html 表单 dom 注意跟表单的name值一致
  6. jsoup httpclient 爬取网页并下载google图标
  7. E2PROM的尺寸
  8. android 多项对话框
  9. [C++程序设计]用数组名作函数参数
  10. Confluence 6 配置 Office 转换器
  11. 题解——CF Manthan, Codefest 18 (rated, Div. 1 + Div. 2) T4(模拟)
  12. 《面向对象程序设计》c++第六次作业___calculator SE
  13. CNN中的池化层的理解和实例
  14. android自动化之appium的环境搭建
  15. Java词频统计
  16. Codeforces 990B :Micro-World
  17. Reflow(回流)和Repaint(重绘) (转)
  18. matplotlib 练习
  19. C#中的yield
  20. 嵌入式开发 MCU

热门文章

  1. 【ZJOI2017 Round1后记】
  2. Uva -1515 Pool construction(最小割)
  3. MySQL查询去重语句
  4. 正则表达式的捕获组(capture group)在Java中的使用
  5. HFile存储格式
  6. Codeforces(429D - Tricky Function)近期点对问题
  7. C#项目的生成事件及批处理文件
  8. 李维对VCL理解的几个错误
  9. 动态代理3--Spring AOP分析
  10. Centos7 防火墙firewalld配置