The Perfect Stall
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21868   Accepted: 9809

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but
it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and,
of course, a cow may be only assigned to one stall. 

Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds
to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will
be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2

Sample Output

4

#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
#define MAXN 100000+10
vector<int>G[10000];
int pipei[MAXN],used[MAXN],n,m;
int find(int u)
{
for(int i=0;i<G[u].size();i++)
{
int v=G[u][i];
if(!used[v])
{
used[v]=1;
if(pipei[v]==-1||find(pipei[v]))
{
pipei[v]=u;
return 1;
}
}
}
return 0;
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=1;i<=n;i++)
G[i].clear();
memset(pipei,-1,sizeof(pipei));
for(int i=1;i<=n;i++)
{
int t;
scanf("%d",&t);
while(t--)
{
int a;
scanf("%d",&a);
G[i].push_back(a);
}
}
int ans=0;
for(int i=1;i<=n;i++)
{
memset(used,0,sizeof(used));
ans+=find(i);
}
printf("%d\n",ans);
}
return 0;
}

最新文章

  1. SQL开发技巧(二)
  2. .net获取本机公网IP代码
  3. ubuntu下cacti安装配置
  4. shell的查找与替换
  5. 转HTMLTestRunner 生成测试报告
  6. Valgrind 安装与使用
  7. unity音频组件
  8. NSIS:判断程序是否运行并进行卸载
  9. mvc路由
  10. Java 面试宝典
  11. 【46】java对象的三个特征(oop)
  12. vue-render函数和插槽
  13. day 35 线程
  14. springboot 学习之路 6(定时任务)
  15. css实现文本溢出显示省略号
  16. LeetCode(976. 三角形的最大周长)
  17. CSS和DIV
  18. 国外程序员整理的C++资源大全
  19. 开启curl函数功能
  20. 微信jsapi退款操作

热门文章

  1. maven——项目构建和依赖管理工具
  2. jQuery——尺寸位置
  3. 从JavaScript的单线程执行说起
  4. ABP生成错误:必须添加对程序集“netstandard”的引用
  5. Centos6.7 编译安装 MySQL教程
  6. XML在线转化为JSON
  7. [SQL Service]从一张表取值更新另一张表字段
  8. python 函数编写指南
  9. 6.3.4 使用marshal 模块操作二进制文件
  10. Codeforces 263C. Appleman and Toastman