Babelfish

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100000100000 dictionary entries, followed by a blank line, followed by a message of up to 100000100000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a non-empty sequence of at most 1010lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as “eh”.

Sample Input 1 Sample Output 1
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay atcay
ittenkay
oopslay
cat
eh
loops

题意

前面那部分是字典里的,后面就查找给出的字符串有没有属于前面的字典里,有的话就输出那个单词

思路

用map存就行了

代码

#include<bits/stdc++.h>
using namespace std;
map<string,string> m;
int main(){
string line,a,b;
while(getline(cin,line)&&line!=""){
stringstream s(line);//格式转换
s>>a;
s>>b;
m[b]=a;
}
while(cin>>b){
a=m[b];
cout<<(a==""?"eh":a)<<endl;
}
}

最新文章

  1. asp.net sqlite 当插入数据后的第一次访问会变的很慢!
  2. malloc原理和内存碎片[转]
  3. [译]SpringMVC自定义验证注解(SpringMVC custom validation annotations)
  4. Git学习(4)基本操作
  5. Uva10082 WERTYU -S.B.S.
  6. OAuth2.0详解
  7. c# winform 关于DataGridView的一些操作(很全,绝对够用)
  8. 车牌识别LPR(二)-- 车牌特征及难点
  9. PostgreSql入门命令
  10. C# Excel嵌入到Winform
  11. Java反射-高级知识掌握
  12. 【学习笔记】Spring JdbcTemplate (3-3-3)
  13. Y1E001 HDI二阶板、三阶板
  14. kubernetes学习01—kubernetes介绍
  15. Verilog笔记——Verilog数字系统设计(第二版)夏宇闻
  16. selemium 常用查找方法
  17. Python第2天
  18. MVC数据列表展示【三】
  19. java 报错英文
  20. hibernate一级缓存和二级缓存的区别

热门文章

  1. 团体程序设计天梯赛-练习集-L1-025. 正整数A+B
  2. 推荐一款能支持国密SM2浏览器——密信浏览器
  3. CentOS 7 yum 安装redis(更简单)
  4. WSDL详解(一)
  5. XSS Chanllenges 6-10
  6. XPath语法简明介绍
  7. Java 超类引用子类对象的示例代码
  8. js中Number()、parseInt()和parseFloat()的区别进行详细介绍
  9. HDU 1475 Pushing Boxes
  10. BJFU fudq的等式