最短路+01背包

In Action

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3857    Accepted Submission(s): 1229

Problem Description


Since 1945, when the first nuclear bomb was exploded by the Manhattan Project team in the US, the number of nuclear weapons have soared across the globe.

Nowadays,the crazy boy in FZU named AekdyCoin possesses some nuclear weapons and wanna destroy our world. Fortunately, our mysterious spy-net has gotten his plan. Now, we need to stop it.

But the arduous task is obviously not easy. First of all, we know that the operating system of the nuclear weapon consists of some connected electric stations, which forms a huge and complex electric network. Every electric station has its power value. To start
the nuclear weapon, it must cost half of the electric network's power. So first of all, we need to make more than half of the power diasbled. Our tanks are ready for our action in the base(ID is 0), and we must drive them on the road. As for a electric station,
we control them if and only if our tanks stop there. 1 unit distance costs 1 unit oil. And we have enough tanks to use.

Now our commander wants to know the minimal oil cost in this action.
 
Input
The first line of the input contains a single integer T, specifying the number of testcase in the file.

For each case, first line is the integer n(1<= n<= 100), m(1<= m<= 10000), specifying the number of the stations(the IDs are 1,2,3...n), and the number of the roads between the station(bi-direction).

Then m lines follow, each line is interger st(0<= st<= n), ed(0<= ed<= n), dis(0<= dis<= 100), specifying the start point, end point, and the distance between.

Then n lines follow, each line is a interger pow(1<= pow<= 100), specifying the electric station's power by ID order.
 
Output
The minimal oil cost in this action.

If not exist print "impossible"(without quotes).
 
Sample Input
2
2 3
0 2 9
2 1 3
1 0 2
1
3
2 1
2 1 3
1
3
 
Sample Output
5
impossible
 
Author
Lost@HDU
 
Source
 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm> using namespace std; const int INF=0x3f3f3f3f; int n,m;
int dist[110],vis[110],power[110];
int g[110][110];
int dp[11000]; void dijkstra()
{
memset(dist,63,sizeof(dist));
memset(vis,0,sizeof(vis)); dist[0]=0; for(int j=0;j<=n;j++)
{
int mark=-1,mindist=INF;
for(int i=0;i<=n;i++)
{
if(vis[i]) continue;
if(mindist>dist[i])
{
mindist=dist[i]; mark=i;
}
} if(mark==-1) break;
vis[mark]=1; for(int i=0;i<=n;i++)
{
if(vis[i]) continue;
dist[i]=min(dist[i],dist[mark]+g[mark][i]);
}
}
} int main()
{
int T_T;
scanf("%d",&T_T);
while(T_T--)
{
memset(g,63,sizeof(g)); scanf("%d%d",&n,&m); for(int i=0;i<m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
g[a][b]=g[b][a]=min(g[a][b],c);
} dijkstra(); int sumd=0,sum=0; for(int i=1;i<=n;i++)
{
scanf("%d",power+i);
if(dist[i]!=INF) sumd+=dist[i];
sum+=power[i];
} memset(dp,0,sizeof(dp)); for(int i=1;i<=n;i++)
{
if(dist[i]==INF) continue;
for(int j=sumd;j>=dist[i];j--)
{
dp[j]=max(dp[j],dp[j-dist[i]]+power[i]);
}
}
int ans=-1,low=0,high=sumd,mid;
while(low<=high)
{
mid=(low+high)/2;
if(dp[mid]*2>sum)
ans=mid,high=mid-1;
else low=mid+1;
} if(ans==-1)
puts("impossible");
else printf("%d\n",ans);
}
return 0;
}

最新文章

  1. HTML CSS 特殊字符表(转载)
  2. 备份MySQL数据库
  3. ajax和sap以及网络安全
  4. Java 6.15习题
  5. Ov
  6. 【POJ】【1635】Subway Tree Systems
  7. Ubuntu 13.10 安装Qt5
  8. 游戏被App Store下架 如何快速上线?
  9. PostgreSQL的 initdb 源代码分析之二十二
  10. oracle report err:REP-2103 PL/SQL formula returned invalid value or no value
  11. HTTP Authorization
  12. Java分布式优秀资源集合
  13. mybatis学习笔记1.零碎记录
  14. POJ 2406 Power Strings(KMP)
  15. 性能测试相关(TPS/RT/PV等)(转)
  16. linux centos7添加ip黑名单禁止某个ip访问
  17. Springmvc 使用 AbstractExcelView 导出excel
  18. C# 调用win32 DLL报错 System.BadImageFormatException
  19. listView 滑动时 滑到一半自动滑动到对应的位置
  20. hdu 1874 畅通工程 【spfa and dijkstra实现】

热门文章

  1. 修改linux内核开机logo并居中全屏显示【转】
  2. ubuntu刚安装好之后apt-get使用异常
  3. BZOJ 1507 splay
  4. Solr快速入门(一)
  5. 云信 短信发送 demo
  6. (转)19 个 JavaScript 有用的简写技术
  7. 【Oracle】跟踪文件目录(User_Dump_Dest)生成脚本(11g/9i).txt
  8. 使用Windows上Eclipse远程调试Linux上的Hadoop
  9. DP:***24种设计模式--转自刘伟
  10. RxSwift文档搜集与备份