Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 17766   Accepted: 6674

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 



We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 



1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 

2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 



The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 



There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

题意:对一个给定size且初始化为0的矩阵。运行一些命令,Q A B为查看arr[a][b]元素的值,C X1 Y1 X2 Y2为将(x1, y1) (x2, y2)矩形范围内的全部点0、1翻转。

题解:树状数组模式二的使用方法。段更新,点查询。update(x2, y2)表示从(1, 1)到(x2, y2)范围内的全部点都要翻转一次,可是这样会把给定范围外的一些点也翻转到,因此须要将这些点翻转回去。

#include <stdio.h>
#include <string.h>
#define maxn 1002 int size, tree[maxn][maxn]; int lowBit(int x){ return x & (-x); } //向下更新表示A[1]...A[i]每一个元素都要 += val,推广到二维同理
void update(int x, int y, int val)
{
int temp;
while(x > 0){
temp = y;
while(temp > 0){
tree[x][temp] += val;
temp -= lowBit(temp);
}
x -= lowBit(x);
}
} int query(int x, int y)
{
int sum = 0, temp;
while(x <= size){
temp = y;
while(temp <= size){
sum += tree[x][temp];
temp += lowBit(temp);
}
x += lowBit(x);
}
return sum;
} int main()
{
//freopen("stdin.txt", "r", stdin); int cas, q, a, b, c, d;
char com[2];
scanf("%d", &cas); while(cas--){
scanf("%d%d", &size, &q);
memset(tree, 0, sizeof(tree)); while(q--){
scanf("%s%d%d", com, &a, &b);
if(com[0] == 'C'){
scanf("%d%d", &c, &d);
update(c, b - 1, -1);
update(a - 1, d, -1);
update(a - 1, b - 1, 1);
update(c, d, 1);
}else printf("%d\n", query(a, b) & 1);
} if(cas) printf("\n");
}
return 0;
}

最新文章

  1. C# : CEF操作
  2. linux添加开机自启动脚本示例详解
  3. 算法_栈与队列的Java链表实现
  4. UVAlive3662 Another Minimum Spanning Tree 莫队算法
  5. StrokeStart与StrokeEnd动画
  6. [Leetcode][Python]42: Trapping Rain Water
  7. Python conda安装 并安装Tensorflow
  8. 解决Linux文件系统变成只读的方法
  9. CSRF与JSON
  10. 《Java程序设计》 第二周学习总结
  11. 截取字符串中最后一个中文词语(MS SQL)
  12. JAVA获取系统相关信息
  13. [翻译] JKLLockScreenViewController
  14. 合格前端系列第六弹-从指向看JavaScript
  15. WCF(一) 创建第一个WCF
  16. shell脚本学习总结08--比较与测试
  17. 对C++虚函数使用默认参数的注意事项
  18. web.xml中配置classpath:和classpath*:的区别和意思
  19. mybatis入门(三):mybatis的基础特性
  20. vector sort AND 友元

热门文章

  1. (转)淘淘商城系列——使用maven构建工程
  2. discuz 插件核心函数hookscript分析.
  3. sh NonUniqueObjectException
  4. C 语言指针 5 分钟教程
  5. CSU 2018年12月月赛 H(2220): Godsend
  6. 笔试算法题(39):Trie树(Trie Tree or Prefix Tree)
  7. 树莓派 - platform总线,设备和驱动
  8. xphrof性能分析线上部署实践
  9. Quartz--01
  10. 09-看图理解数据结构与算法系列(B树)