http://poj.org/problem?id=2031

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 

The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is
quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 



All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or
(3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 



You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least
three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with
the shortest total length of the corridors. 



You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form
a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 





x1 y1 z1 r1 

x2 y2 z2 r2 

... 

xn yn zn rn 



The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 



The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after
the decimal point. Values are separated by a space character. 



Each of x, y, z and r is positive and is less than 100.0. 



The end of the input is indicated by a line containing a zero. 

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 



Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

/*

题目大意:太空建站,有n个点x,y,z,各有一个半径。有可能会有一个空间站吧还有一个覆盖,距离就是0。然后就是求最小生成树的总和

*/

#include <stdio.h>
#include <math.h>
#include <string.h>
#define INF 0x3f3f3f3f
#define N 110
int n;
double x[N];
double y[N];
double z[N];
double r[N];
double map[N][N];//两点的距离
double low[N];//最短距离
bool vis[N]; double fun(int i,int j)
{
double temp=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])+(z[i]-z[j])*(z[i]-z[j]))-(r[i]+r[j]);
if(temp<0) return 0;
return temp;
}
void prim()
{
int pos=1;
int i,j;
double sum=0;
memset(vis,0,sizeof(vis));
for(i=1;i<=n;++i)
low[i]=INF; for(i=1;i<=n;++i)//第一次给low赋值
{
low[i]=map[1][i];
}
vis[1]=1;//已经找到一个
low[1]=0;
for(i=1;i<n;++i)//再找n-1个点
{
double min=INF;
for(j=1;j<=n;++j)
{
if(!vis[j]&&min>low[j])
{
min=low[j];
pos=j;
}
}
if(min==INF)
{
printf("0.000\n");
return ;
}
vis[pos]=1;
sum+=min;
for(j=1;j<=n;++j)//low的更新
{
if(!vis[j]&&low[j]>map[pos][j])
low[j]=map[pos][j];
}
}
printf("%.3f\n",sum);
}
int main()
{
int i,j;
while(~scanf("%d",&n),n)
{
for(i=1;i<=n;++i)
{
scanf("%lf%lf%lf%lf",x+i,y+i,z+i,r+i);
}
for(i=1;i<=n;++i)
{
for(j=1;j<=i;++j)
{
map[i][j]=map[j][i]=fun(i,j);
}
}
prim();
} return 0;
}

最新文章

  1. Android多种进度条使用详解
  2. Android Gradle的使用
  3. SQL2008性能计数器注册表配置单元一致性失败
  4. 转:CWnd的函数,以后可以在这儿找了!
  5. AndroidStudio支持新的NDK的操作使用
  6. fscanf()功能具体解释
  7. struct stat结构体简介
  8. for循环,数字类型,字符串类型
  9. [转]Ble蓝牙的使用手册
  10. Rust hello world !
  11. 如何使用 MasterPage
  12. vue基础——vue介绍
  13. 微信小程序开发,服务器端获取不到请求参数
  14. 矩阵分解---QR正交分解,LU分解
  15. 《Spring2之站立会议1》
  16. LeetCode——Power of Two
  17. python if-elif-else 结构判断输入值处于何种年龄段
  18. [Android]Caused by: java.lang.IllegalArgumentException: Service not registered.md
  19. Jmeter对HTTP请求压力测试、并发测试
  20. JS获取 KindEditor textarea 标签 html内容失败的解决方法。

热门文章

  1. [caffe]网络各层参数设置
  2. C++函数传递数组的两种方式
  3. poj 3311 Hie with the Pie (状压dp) (Tsp问题)
  4. MyBatis学习总结(2)——使用MyBatis对表执行CRUD操作
  5. POJ3684 Physics Experiment 【物理】
  6. HDU 4314 Contest 2
  7. Android本地存储方案 SharedPreferences
  8. 安卓中经常使用控件遇到问题解决方法(持续更新和发现篇幅)(在textview上加一条线、待续)
  9. 343D/Codeforces Round #200 (Div. 1) D. Water Tree dfs序+数据结构
  10. 20.boost dijkstra最短路径算法