Currency Exchange

Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, CAB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题目大意:给你n种货币,m种货币交换关系,交换率和手续费,给你起始的货币类型和金额,问你是否可以通过交换货币,最后回到起始的货币时能盈利。

解题思路:如果要盈利,只需要判断图中存不存在正环, 即可以一直让某种货币额度无限增加。由于是无向图,那么只要存在正环,那么我就可以最后转化成起始的货币且盈利。所以只要将SPFA判负环的条件变化一下就行。初始值时,让除原点之外的d数组都赋值为0。同时松弛条件变为d[e.to] < (d[e.from] - e.com)*e.rate。即可,最后判断当u为起点时的d[u]是否大于起始金额即可。

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
#include<vector>
#include<iostream>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 1e3+200;
int n , m;
struct Edge{
int from,to;
double rate , com;
};
vector<Edge>edges;
vector<int>G[maxn];
void init(){
for(int i = 0; i <= n; i++){
G[i].clear();
}
edges.clear();
}
double d[maxn] ,cnt[maxn], inq[maxn];
void AddEdge(int u,int v,double r,double co){
edges.push_back( (Edge){u,v,r,co} );
m = edges.size();
G[u].push_back(m-1);
} bool SPFA(int s, double V){
queue<int>Q;
for(int i = 0; i <= n; i++){
d[i] = 0;
}
d[s] = V;
cnt[s] ++;
inq[s] = 1;
Q.push(s);
while(!Q.empty()){
int u = Q.front();
Q.pop();
if(u == s&& d[s] > V){
return true;
}
inq[u] = 0;
for(int i = 0; i < G[u].size(); i++){
Edge & e = edges[G[u][i]];
if(d[e.to] < (d[e.from] - e.com)*e.rate ){
d[e.to ] = (d[e.from] - e.com) *e.rate;
if(!inq[e.to]){
inq[e.to] = 1;
Q.push(e.to);
}
}
}
}
return false;
}
int main(){
int mm,s;
double k;
while(scanf("%d%d%d%lf",&n,&mm,&s,&k)!=EOF){
int a,b;
double c,d;
for(int i = 0; i < mm; i++){
scanf("%d%d%lf%lf",&a,&b,&c,&d);
AddEdge(a,b,c,d);
scanf("%lf%lf",&c,&d);
AddEdge(b,a,c,d);
}
bool yes = SPFA(s,k);
if(yes){
puts("YES");
}else{
puts("NO");
}
}
return 0;
}

  


最新文章

  1. WCF Basics - FAQs Series【WCF基础----问答系列教程】
  2. docker学习(5) 在mac中创建mysql docker容器
  3. org.hibernate.HibernateException: No Session found for current thread
  4. iOS 源代码管理工具之SVN
  5. LoadRunner录制图片验证码
  6. 第2章 面向对象的设计原则(SOLID):4_接口隔离原则(ISP)
  7. C#窗体-&gt;&gt;随机四则运算
  8. OverHust
  9. doc 窗口操作图
  10. 选择 GCD 还是 NSTimer
  11. PL/SQL学习笔记_01_基础
  12. kvm热添加和热迁移
  13. 使用OMS查询Api Management的调用日志
  14. windows server 2008 R2之取消多余的安全配置
  15. 【Tomcat】压力测试和优化
  16. CUDNN安装
  17. LeetCode 151 翻转字符串里的单词
  18. UI学习网站
  19. Linux学习笔记:Jenkins安装
  20. Shell调试篇 转

热门文章

  1. epoll简介
  2. 787. Cheapest Flights Within K Stops
  3. 高产的母猪之 python __init__全解
  4. angular原理及模块简介
  5. 树状数组【bzoj1103】: [POI2007]大都市meg
  6. arcgis图片文件
  7. linux下将当前目录下的文件名存到一个文本文件里
  8. 07. 如何实现移动端rem适配
  9. java 学习原生jdbc
  10. day_02 循环格式化输出编码运算符