1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

思考

这里胡凡书上写的不全面,代码修正如下。

AC代码

#include <stdio.h>
#define max_n 1111
double p[max_n] = {};//这样也可以置初值为0
int main() {
int k, n, count = 0;
double a;
scanf("%d", &k);
count +=k;
for(int i = 0; i < k; i++) {
scanf("%d %lf", &n, &a);
p[n] += a;
}
scanf("%d", &k);
count +=k;
for(int i = 0; i < k; i++) {
scanf("%d %lf", &n, &a);
if(p[n]!=0) count--;//出现重合项-1
p[n] += a;
if(p[n]==0) count--;//出现重合项且一正一负抵消为0,再-1
}
// for(int i = 0; i < max_n; i++) {
// if(p[i] != 0) {
// count++;
// }//这样计数非零项是保险的
// }
printf("%d", count);
for(int i = max_n - 1; i >= 0; i--) {
if(p[i] != 0) printf(" %d %.1f", i, p[i]);
}
return 0;
}

最新文章

  1. 几款开源ESB总线的比较
  2. 解决使用osgModeling的Loft生成管子时的bug
  3. python 实现彻底删除文件夹和文件夹下的文件
  4. 《CSS3秘籍》(第三版)-读书笔记(4)
  5. 美国H1B基本情况及相关数据
  6. VisualStudio自定义代码段_方法二
  7. SQL2005性能分析一些细节功能你是否有用到?(三)
  8. shell小脚本工具合集
  9. Python实现删除目录下相同文件
  10. Tomcat与Nginx、Apache结合的相关实践
  11. curl支持HTTP和https
  12. ORACLE知识点总结
  13. java Web三大组件--监听器
  14. 通过反射来读取XML格式的ControlTemplate
  15. 如何安装ipa文件(二)
  16. 网络上可供测试的Web Service
  17. 如何加速tomcat启动速度
  18. Codeforces Round #298 (Div. 2) D. Handshakes 构造
  19. centos 正则,grep,egrep,流式编辑器 sed,awk -F 多个分隔符 通配符 特殊符号. * + ? 总结 问加星 cat -n nl 输出文件内容并加上行号 alias放~/.bash_profile 2015-4-10 第十三节课
  20. Codeforces Round #534 (Div. 2) Solution

热门文章

  1. hibernate课程 初探单表映射1-7 hibernate配置文件新建
  2. 【C++函数重载】求3个数中最大的数(分别考虑整数、双精度数、长整数的情况)。
  3. SpringBoot的核心功能
  4. 如何修改HDFS上文件
  5. sql server 2012不能全部用到CPU的逻辑核心数的问题
  6. centos6.5_64bit-nginx安装部署
  7. Python开发第二篇
  8. Excel如何显示隐藏列?
  9. hdu-1179 Ollivanders: Makers of Fine Wands since 382 BC.---二分图匹配模板
  10. 【BZOJ1013】[JSOI2008] 球形空间产生器(高斯消元)