Evacuation

题目连接:

http://poj.org/problem?id=3057

Description

Fires can be disastrous, especially when a fire breaks out in a room that is completely filled with people. Rooms usually have a couple of exits and emergency exits, but with everyone rushing out at the same time, it may take a while for everyone to escape.

You are given the floorplan of a room and must find out how much time it will take for everyone to get out. Rooms consist of obstacles and walls, which are represented on the map by an 'X', empty squares, represented by a '.' and exit doors, which are represented by a 'D'. The boundary of the room consists only of doors and walls, and there are no doors inside the room. The interior of the room contains at least one empty square.

Initially, there is one person on every empty square in the room and these persons should move to a door to exit. They can move one square per second to the North, South, East or West. While evacuating, multiple persons can be on a single square. The doors are narrow, however, and only one person can leave through a door per second.

What is the minimal time necessary to evacuate everybody? A person is evacuated at the moment he or she enters a door square.

Input

The first line of the input contains a single number: the number of test cases to follow. Each test case has the following format:

One line with two integers Y and X, separated by a single space, satisfying 3 <= Y, X <= 12: the size of the room

Y lines with X characters, each character being either 'X', '.', or 'D': a valid description of a room

Output

For every test case in the input, the output should contain a single line with the minimal evacuation time in seconds, if evacuation is possible, or "impossible", if it is not.

Sample Input

3

5 5

XXDXX

X...X

D...X

X...D

XXXXX

5 12

XXXXXXXXXXXX

X..........D

X.XXXXXXXXXX

X..........X

XXXXXXXXXXXX

5 5

XDXXX

X.X.D

XX.XX

D.X.X

XXXDX

Sample Output

3

21

impossible

Hint

题意

一副迷宫图'.'为空格,'D'为门,'#'为墙;

现在每个空格处有一人,且每个时刻每个空格只能站一人;当走到门时为离开房间;求所有人撤离的最短时间,否则impossible;

题解:

二分答案,然后建图跑网络流去check就好了

二分t

S连向每个人,流量为1。每个人向t秒能到达的门流量为1。每个门向T连流量为t的边。然后看是不是满流。

代码

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
const int MAXN=100000,MAXM=100000,inf=1e9;
struct Edge
{
int v,c,f,nx;
Edge() {}
Edge(int v,int c,int f,int nx):v(v),c(c),f(f),nx(nx) {}
} E[MAXM];
int G[MAXN],cur[MAXN],pre[MAXN],dis[MAXN],gap[MAXN],N,sz;
void init(int _n)
{
N=_n,sz=0; memset(G,-1,sizeof(G[0])*N);
}
void link(int u,int v,int c)
{
E[sz]=Edge(v,c,0,G[u]); G[u]=sz++;
E[sz]=Edge(u,0,0,G[v]); G[v]=sz++;
}
bool bfs(int S,int T)
{
static int Q[MAXN]; memset(dis,-1,sizeof(dis[0])*N);
dis[S]=0; Q[0]=S;
for (int h=0,t=1,u,v,it;h<t;++h)
{
for (u=Q[h],it=G[u];~it;it=E[it].nx)
{
if (dis[v=E[it].v]==-1&&E[it].c>E[it].f)
{
dis[v]=dis[u]+1; Q[t++]=v;
}
}
}
return dis[T]!=-1;
}
int dfs(int u,int T,int low)
{
if (u==T) return low;
int ret=0,tmp,v;
for (int &it=cur[u];~it&&ret<low;it=E[it].nx)
{
if (dis[v=E[it].v]==dis[u]+1&&E[it].c>E[it].f)
{
if (tmp=dfs(v,T,min(low-ret,E[it].c-E[it].f)))
{
ret+=tmp; E[it].f+=tmp; E[it^1].f-=tmp;
}
}
}
if (!ret) dis[u]=-1; return ret;
}
int dinic(int S,int T)
{
int maxflow=0,tmp;
while (bfs(S,T))
{
memcpy(cur,G,sizeof(G[0])*N);
while (tmp=dfs(S,T,inf)) maxflow+=tmp;
}
return maxflow;
} char s[23][23];
int dx[4]={1,-1,0,0};
int dy[4]={0,0,1,-1};
int n,m;
int vis[23][23];
int d[405][23][23];
vector<int> doorx,doory;
void doit()
{
for(int i=0;i<doorx.size();i++)
{
int x=doorx[i],y=doory[i];
queue<int>qx,qy;
d[i][x][y]=0;
qx.push(x),qy.push(y);
while(!qx.empty())
{
x=qx.front(),y=qy.front();
qx.pop(),qy.pop();
for(int j=0;j<4;j++)
{
int nx=x+dx[j],ny=y+dy[j];
if(nx<0||nx>=n)continue;
if(ny<0||ny>=m)continue;
if(s[nx][ny]=='D'||s[nx][ny]=='X')continue;
if(d[i][nx][ny]>d[i][x][y]+1)
{
d[i][nx][ny]=d[i][x][y]+1;
qx.push(nx);
qy.push(ny);
}
}
}
}
}
bool check(int t)
{
init(10005);
int S = 9999,T = 10000;
int cnt = 0;
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
{
if(s[i][j]=='.')
link(S,i*m+j,1),cnt++;
if(s[i][j]=='D')
link(i*m+j,T,t);
}
for(int i=0;i<doorx.size();i++)
for(int j=0;j<n;j++)
for(int k=0;k<m;k++)
if(d[i][j][k]<=t&&s[j][k]=='.')
link(j*m+k,doorx[i]*m+doory[i],1);
int cnt2 = dinic(S,T);
if(cnt==cnt2)return true;
return false;
}
int main()
{
int t;scanf("%d",&t);
while(t--){
doorx.clear(),doory.clear();
memset(s,0,sizeof(s));
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
scanf("%s",s[i]);
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
if(s[i][j]=='D')
doorx.push_back(i),doory.push_back(j);
for(int i=0;i<=400;i++)
for(int j=0;j<23;j++)
for(int k=0;k<23;k++)
d[i][j][k]=inf;
doit();
int l=0,r=500,ans=-1;
while(l<=r)
{
int mid = (l+r)/2;
if(check(mid))ans=mid,r=mid-1;
else l=mid+1;
}
if(ans==-1)printf("impossible\n");
else printf("%d\n",ans);
}
}

最新文章

  1. Spring MVC中Action使用总结
  2. SQL Server 索引和表体系结构(三)
  3. JS实现漂亮的窗口拖拽效果(可改变大小、最大化、最小化、关闭)
  4. IronPython调用C# DLL函数方法
  5. textview的上下滑动效果
  6. 주기적으로 php파일 실행시키기 (PHP 파일 cron 으로 돌리기)
  7. sqlalchemy通过ssh连接远程mysql服务器
  8. 非常贴心的轮子 FreeSql
  9. 分布式系列四: HTTP及HTTPS协议
  10. [转载] java多线程总结(一)
  11. svg中实现文字随曲线走向,HTML直接写和JavaScript创建对象两种方式
  12. Java内存模型概念简单介绍,想深入自行百度
  13. GIT 简单版
  14. [ACM_暴力] 最多交换k个数的顺序,求a[i]的最大连续和
  15. iconfont的引入方法
  16. 20155327 2016-2017-3 《Java程序设计》第4周学习总结
  17. JQuery事件机制
  18. python3 - 元组、集合
  19. 解析PHP中如何将数组变量写入文件
  20. 下载并安装Prism5.0库 Download and Setup Prism Library 5.0 for WPF(英汉对照版)

热门文章

  1. netcat、nc工具随记
  2. 寻找kernel32.dll的地址
  3. GCC在C语言中内嵌汇编 asm __volatile__ 【转】
  4. monkey测试===如何获取android app的Activity
  5. U-Boot启动过程完全分析&lt;转&gt;
  6. 文字顺时针旋转90度(纵向)&amp;古诗词排版
  7. AtomicReference 和 volatile 的区别
  8. redis之(七)redis的集合类型的命令
  9. google code-prettify 代码高亮插件使用方法
  10. 在 Ubuntu 系统安装 Redi