http://acm.hdu.edu.cn/showproblem.php?pid=1338

Problem Description
Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.
 
Input
The input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.

 
Output
For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.
 
Sample Input
2 5
1 7 2 10 9
 
6 11
62 63 54 66 65 61 57 56 50 53 48
 
0 0
 
Sample Output
Case 1: 2
Case 2: 4
 
题解:贪心 排序
代码:

#include <bits/stdc++.h>
using namespace std; int N, M;
int num[55]; int main() {
int Case = 0;
while(~scanf("%d%d", &N, &M)) {
Case ++;
if(!N && !M) break;
for(int i = 1; i <= M; i ++) {
scanf("%d", &num[i]);
} int maxx = N * M;
int cnt = 0;
sort(num + 1, num + 1 + M);
for(int i = M; i >= 1; i --) {
if(num[i] >= maxx) {
cnt ++;
maxx --;
}
else maxx -= 2;
}
printf("Case %d: %d\n", Case, cnt);
}
return 0;
}

  

最新文章

  1. 用Fiddler做为手机的上网代理
  2. crontab的坑
  3. DCMTK3.6.1(MD支持库)安装说明
  4. int转多进制
  5. ubuntu12.04上搭建darwin streaming server6.03
  6. [读书笔记]了不起的node.js(二)
  7. windows azure tools for mac
  8. xamarin SimpleAdapter绑定出错问题
  9. 【转】Android(4.2) Sensors 学习——G-sensor,Gyroscope驱动移植
  10. Webpack学习笔记(一)
  11. Firefox driver 那些事~
  12. python使用装饰器对文件进行读写操作&#39;及遍历文件目录
  13. 2018.11.01 NOIP训练 某种密码(折半搜索)
  14. ActiveMQ——activemq的报错见解javax.jms.JMSException: Software caused connection abort: recv failed
  15. 基于SpringSecurity和JWT的用户访问认证和授权
  16. python获取两个dict的不同
  17. chrome和Firefox对p标签中单词换行的渲染(强制换行)
  18. overflow: auto 图片自适应调整
  19. 4 python内置函数
  20. p12转pem公钥私钥

热门文章

  1. c# 常用数据库封装
  2. django-orm简记
  3. centos7-mongodb3.4.6集群的搭建
  4. js判断两个日期是否在几个月之内
  5. django 面试题
  6. JDK7 新特性
  7. Apache httpd Server 配置正向代理
  8. Thinkphp5所有页面验证用户是否登陆
  9. 网络编程之socket的运用
  10. python中一些内置函数实例