Stars

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 58255   Accepted: 24860

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

 
话不多说,都在代码里了..
/*
读题很容易知道,每一颗star i 只需要那些满足 j.time < i.time and j.row <= i.row的star即可,依题意我们知道这刚好就是输入顺序。
so 我们只需要选择那些在某个star之前放的并且row小于等于他的star。
所以我们可以把i.row插入,即可查出在某个数j插入之前row.i < row.j的数量
*/
#include <cstdio>
using namespace std; const int maxn = 32000 + 5;
int n, c[maxn], ans[maxn]; int lowbit(int x) {
return x & (-x);
} void add(int x, int d) {
while(x <= maxn) {
c[x] += d;
x += lowbit(x);
}
} int query(int x) {
int sum = 0;
while(x > 0) {
sum += c[x];
x -= lowbit(x);
}
return sum;
} int main() {
int x, y;
scanf("%d", &n);
for(int i = 0; i < n; i ++) {
scanf("%d %d", &x, &y);
x += 1;
ans[query(x)] ++;
add(x, 1);
}
for(int i = 0; i < n; i ++) {
printf("%d\n", ans[i]);
}
return 0;
}
 
 

最新文章

  1. sql server项目死活启动不了的问题
  2. linux下如何安装webbench
  3. webpack 教程 那些事儿04-webpack项目实战分析
  4. nyoj1000_快速幂_费马小定理
  5. [DB那些事]数据库加密
  6. C#委托之泛型
  7. zoj1610 线段树
  8. 查看SQL语句执行时间、IO开销
  9. Python计算机视觉3:模糊,平滑,去噪
  10. 多线程并发编程之显示锁ReentrantLock和读写锁
  11. php——SoapClient访问webservice
  12. uva 408 Uniform Generator
  13. VS2008编译汇编程序的问题
  14. 关系型数据库工作原理-数据库整体框架(翻译自Coding-Geek文章)
  15. KVM之五:KVM日常管理常用命令
  16. MySQL文档翻译(八)附英文原文---性能优化概览
  17. equals方法中变量在前和在后的区别
  18. Java学习笔记(二十三):final关键字
  19. array_column的作用
  20. LeetCode题解之Sort List

热门文章

  1. 工作中常用到的linux命令总结
  2. jenkins git项目clean before checkout 和 wipe out repository &amp; force clone
  3. svn 命令行使用总结
  4. php内置函数分析array_count_values()
  5. C文件 CMakeList.txt编译器配置错误的问题 error:invalid conversion from &#39;int&#39; to &#39;LAYER_TYPE&#39; [-fpermissive]....
  6. UITableView和MJReFresh结合使用问题记录
  7. sql2008 误操作还原至指定时间点
  8. Java 内存屏障
  9. Spring Cloud Commons教程(一)普通抽象
  10. WinSetupFromUSB - 超简单制作多合一系统安装启动U盘的工具 (支持Win/PE/Linux启动盘)