这是一个综合的实验,包含了静态路由、默认路由、RIPOSPF四种路由。通过配置,最终实现全网互通。


实验拓扑

如图所示连接,地址规划如下:

名称 接口 IP地址
R1 f0/0 192.168.10.1/24
R1 f0/1 192.168.20.1/24
R2 f0/0 192.168.20.2/24
R2 f0/1 192.168.30.1/24
R3 f0/0 192.168.30.2/24
R3 f0/1 192.168.40.1/24
R3 f1/0 12.0.0.1/24
R3 f2/0 192.168.70.1/24
R4 f0/0 192.168.40.2/24
R4 f0/1 192.168.50.1/24
R5 f0/0 192.168.50.2/24
R5 f0/1 192.168.60.1/24
R6 f0/0 12.0.0.2/24
R6 f0/1 13.0.0.1/24
PC1 e0 192.168.10.2/24
PC2 e0 192.168.70.2/24
PC3 e0 192.168.60.2/24
Server e0 13.0.0.13/24

实验过程

R1

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int f0/0
R1(config-if)#ip add 192.168.10.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#ex
R1(config)#int f0/1
R1(config-if)#ip add 192.168.20.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#ex
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.20.2

R2

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int f0/0
R2(config-if)#ip add 192.168.20.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#ex
R2(config)#int f0/1
R2(config-if)#ip add 192.168.30.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#ex
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.30.0 0.0.0.255 area 1
R2(config-router)#ex
R2(config)#ip route 192.168.10.0 255.255.255.0 192.168.20.1
R2(config)#router ospf 1
R2(config-router)#redistribute connected subnets
R2(config-router)#redistribute static subnets
R2(config-router)#ex

R3

R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#int f0/0
R3(config-if)#ip add 192.168.30.2 255.255.255.0
R3(config-if)#no sh
R3(config-if)#ex
R3(config)#int f0/1
R3(config-if)#ip add 192.168.40.1 255.255.255.0
R3(config-if)#no sh
R3(config-if)#ex
R3(config)#int f1/0
R3(config-if)#ip add 12.0.0.1 255.255.255.0
R3(config-if)#no sh
R3(config-if)#ex
R3(config)#int f2/0
R3(config-if)#ip add 192.168.70.1 255.255.255.0
R3(config-if)#no sh
R3(config-if)#ex
R3(config)#ip route 0.0.0.0 0.0.0.0 12.0.0.2
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.30.0 0.0.0.255 area 1
R3(config-router)#network 192.168.40.0 0.0.0.255 area 0
R3(config-router)#network 192.168.70.0 0.0.0.255 area 0
R3(config-router)#default-information originate
R3(config-router)#ex

R4

R4#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R4(config)#int f0/0
R4(config-if)#ip add 192.168.40.2 255.255.255.0
R4(config-if)#no sh
R4(config-if)#ex
R4(config)#int f0/1
R4(config-if)#ip add 192.168.50.1 255.255.255.0
R4(config-if)#no sh
R4(config-if)#ex
R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#no auto-summary
R4(config-router)#network 192.168.50.0
R4(config-router)#redistribute ospf 1 metric 5
R4(config-router)#ex
R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 192.168.40.0 0.0.0.255 area 0
R4(config-router)#redistribute rip subnets
R4(config-router)#ex

R5

R5#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R5(config)#int f0/0
R5(config-if)#ip add 192.168.50.2 255.255.255.0
R5(config-if)#no sh
R5(config-if)#ex
R5(config)#int f0/1
R5(config-if)#ip add 192.168.60.1 255.255.255.0
R5(config-if)#no sh
R5(config-if)#ex
R5(config)#router rip
R5(config-router)#version 2
R5(config-router)#no auto-summary
R5(config-router)#network 192.168.50.0
R5(config-router)#network 192.168.60.0
R5(config-router)#ex

R6

R6#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R6(config)#int f0/0
R6(config-if)#ip add 12.0.0.2 255.255.255.0
R6(config-if)#no sh
R6(config-if)#ex
R6(config)#int f0/1
R6(config-if)#ip add 13.0.0.1 255.255.255.0
R6(config-if)#no sh
R6(config-if)#ex
R6(config)#ip route 192.168.0.0 255.255.0.0 12.0.0.1

查看路由表

  • R1
R1(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route Gateway of last resort is 192.168.20.2 to network 0.0.0.0 C 192.168.10.0/24 is directly connected, FastEthernet0/0
C 192.168.20.0/24 is directly connected, FastEthernet0/1
S* 0.0.0.0/0 [1/0] via 192.168.20.2
  • R2
R2(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route Gateway of last resort is 192.168.30.2 to network 0.0.0.0 C 192.168.30.0/24 is directly connected, FastEthernet0/1
O E2 192.168.60.0/24 [110/20] via 192.168.30.2, 00:07:57, FastEthernet0/1
S 192.168.10.0/24 [1/0] via 192.168.20.1
O IA 192.168.40.0/24 [110/20] via 192.168.30.2, 00:22:05, FastEthernet0/1
C 192.168.20.0/24 is directly connected, FastEthernet0/0
O E2 192.168.50.0/24 [110/20] via 192.168.30.2, 00:12:35, FastEthernet0/1
O IA 192.168.70.0/24 [110/11] via 192.168.30.2, 00:21:37, FastEthernet0/1
O*E2 0.0.0.0/0 [110/1] via 192.168.30.2, 00:21:17, FastEthernet0/1
  • R3
R3(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route Gateway of last resort is 12.0.0.2 to network 0.0.0.0 C 192.168.30.0/24 is directly connected, FastEthernet0/0
O E2 192.168.60.0/24 [110/20] via 192.168.40.2, 00:08:05, FastEthernet0/1
O E2 192.168.10.0/24 [110/20] via 192.168.30.1, 00:22:06, FastEthernet0/0
C 192.168.40.0/24 is directly connected, FastEthernet0/1
O E2 192.168.20.0/24 [110/20] via 192.168.30.1, 00:22:06, FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.0.0.0 is directly connected, FastEthernet1/0
O E2 192.168.50.0/24 [110/20] via 192.168.40.2, 00:12:50, FastEthernet0/1
C 192.168.70.0/24 is directly connected, FastEthernet2/0
S* 0.0.0.0/0 [1/0] via 12.0.0.2
  • R4
R4(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route Gateway of last resort is 192.168.40.1 to network 0.0.0.0 O IA 192.168.30.0/24 [110/20] via 192.168.40.1, 00:13:22, FastEthernet0/0
R 192.168.60.0/24 [120/1] via 192.168.50.2, 00:00:03, FastEthernet0/1
O E2 192.168.10.0/24 [110/20] via 192.168.40.1, 00:13:22, FastEthernet0/0
C 192.168.40.0/24 is directly connected, FastEthernet0/0
O E2 192.168.20.0/24 [110/20] via 192.168.40.1, 00:13:22, FastEthernet0/0
C 192.168.50.0/24 is directly connected, FastEthernet0/1
O 192.168.70.0/24 [110/11] via 192.168.40.1, 00:13:22, FastEthernet0/0
O*E2 0.0.0.0/0 [110/1] via 192.168.40.1, 00:13:24, FastEthernet0/0
  • R5
R5(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route Gateway of last resort is 192.168.50.1 to network 0.0.0.0 R 192.168.30.0/24 [120/5] via 192.168.50.1, 00:00:17, FastEthernet0/0
C 192.168.60.0/24 is directly connected, FastEthernet0/1
R 192.168.10.0/24 [120/5] via 192.168.50.1, 00:00:17, FastEthernet0/0
R 192.168.40.0/24 [120/5] via 192.168.50.1, 00:00:17, FastEthernet0/0
R 192.168.20.0/24 [120/5] via 192.168.50.1, 00:00:17, FastEthernet0/0
C 192.168.50.0/24 is directly connected, FastEthernet0/0
R 192.168.70.0/24 [120/5] via 192.168.50.1, 00:00:17, FastEthernet0/0
R* 0.0.0.0/0 [120/1] via 192.168.50.1, 00:00:19, FastEthernet0/0
  • R6
R6(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route Gateway of last resort is not set 12.0.0.0/24 is subnetted, 1 subnets
C 12.0.0.0 is directly connected, FastEthernet0/0
13.0.0.0/24 is subnetted, 1 subnets
C 13.0.0.0 is directly connected, FastEthernet0/1
S 192.168.0.0/16 [1/0] via 12.0.0.1

验证结果

配置 IP 地址

PC1> ip 192.168.10.2 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.2 255.255.255.0 gateway 192.168.10.1
PC2> ip 192.168.70.2 192.168.70.1
Checking for duplicate address...
PC1 : 192.168.70.2 255.255.255.0 gateway 192.168.70.1
PC3> ip 192.168.60.2 192.168.60.1
Checking for duplicate address...
PC1 : 192.168.60.2 255.255.255.0 gateway 192.168.60.1
Server> ip 13.0.0.13 13.0.0.1
Checking for duplicate address...
PC1 : 13.0.0.13 255.255.255.0 gateway 13.0.0.1

ping 测试

PC1> ping 192.168.70.2
192.168.70.2 icmp_seq=1 timeout
192.168.70.2 icmp_seq=2 timeout
84 bytes from 192.168.70.2 icmp_seq=3 ttl=61 time=58.825 ms
84 bytes from 192.168.70.2 icmp_seq=4 ttl=61 time=57.842 ms
84 bytes from 192.168.70.2 icmp_seq=5 ttl=61 time=55.705 ms PC1> ping 13.0.0.13
13.0.0.13 icmp_seq=1 timeout
13.0.0.13 icmp_seq=2 timeout
84 bytes from 13.0.0.13 icmp_seq=3 ttl=60 time=79.911 ms
84 bytes from 13.0.0.13 icmp_seq=4 ttl=60 time=80.635 ms
84 bytes from 13.0.0.13 icmp_seq=5 ttl=60 time=79.938 ms PC1> ping 192.168.60.2
192.168.60.2 icmp_seq=1 timeout
84 bytes from 192.168.60.2 icmp_seq=2 ttl=59 time=100.595 ms
84 bytes from 192.168.60.2 icmp_seq=3 ttl=59 time=95.884 ms
84 bytes from 192.168.60.2 icmp_seq=4 ttl=59 time=99.846 ms
84 bytes from 192.168.60.2 icmp_seq=5 ttl=59 time=101.842 ms

最新文章

  1. 对jquery的ajax进行二次封装
  2. POI2012
  3. Sql 触发器禁用和启用
  4. CSS拉伸resize
  5. C#微信公众号开发系列教程四(接收普通消息)
  6. 监听turtlesim仿真器,发送数据到实际的机器人--20
  7. 计数dp-hdu-4054-Number String
  8. 剪切板 复制文本 ClipboardManager
  9. 网络断开后重连downloadProvider继续下载问题调试分析
  10. Apache HttpClient组件封装工具类
  11. ExifInterface 多媒体文件附加信息
  12. C#之再议数组和集合
  13. python基础-->流程控制-->分支结构-->单项分支-->双向分支
  14. Setup Sight Sense
  15. Java基础知识_毕向东_Java基础视频教程笔记(13 字符)
  16. 利用存储过程来重命名SQL Server数据库
  17. (转)win下修改jdk环境变量后,java版本不变 java -version
  18. ld: warning: directory not found for option '-F/Users/Jason/Project/xxx'
  19. java二维数组遍历
  20. 用idea搭建一个简单的SSM的Demo

热门文章

  1. nuxtjs如何部署cdn及区分发布环境
  2. MybatisPlus使用代码生成器遇到的小问题
  3. 特征值、特征向量与PCA算法
  4. Spring Boot 2.2.1 发布,一个有点坑的版本!
  5. GKE logging查看
  6. Python【每日一问】30
  7. thinkphp 6.0 swoole扩展websocket使用教程
  8. 定时删除10天前的Es索引
  9. flask异常处理:abort、errorhandler、app_errorhandler,封装全局异常处理
  10. Remote System Explorer Operation总是运行后台服务,卡死eclipse解决办法