Babelfish
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 32988   Accepted: 14189

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign
language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source

Waterloo local 2001.09.22
输入一个字典。前面一个单词和后面的单词映射。问给出的单词有没有相应的,有输出,没有,输出eh
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node{
int flag ;
node *next[27] ;
} *head;
node *getnode()
{
node *p = new node ;
int i ;
for(i = 0 ; i < 27 ; i++)
p->next[i] = NULL ;
p->flag = -1 ;
return p ;
}
void gettree(node *p,char *s,int m)
{
int i , k , l = strlen(s);
for(i = 0 ; i < l ; i++)
{
k = s[i] - 'a' ;
if( p->next[k] == NULL )
p->next[k] = getnode();
p = p->next[k] ;
}
p->flag = m ;
}
int f(node *p,char *s)
{
int i , k , l = strlen(s) ;
for(i = 0 ; i < l ; i++)
{
k = s[i] - 'a' ;
if( p->next[k] == NULL )
return -1 ;
p = p->next[k] ;
}
return p->flag;
}
char s1[110000][12] , s2[110000][12] , s[30] ;
int main()
{
int i = 0 , j , l , k ;
head = getnode();
while(1)
{
gets(s);
if(s[0] == '\0')
break;
sscanf(s,"%s %s", s1[i], s2[i]);
gettree(head,s2[i],i);
i++ ;
}
while(gets(s)!=NULL)
{
if(s[0] == '\0')
break;
k = f(head,s);
if(k == -1)
printf("eh\n");
else
printf("%s\n", s1[k]);
}
return 0;
}

版权声明:转载请注明出处:http://blog.csdn.net/winddreams

最新文章

  1. iOS 应用中有页面加载gif动画,从后台进入前台时就消失了
  2. IOS开发之开发者账号遇到的bug
  3. POJ 1523 (割点+连通分量)
  4. flat file
  5. 【转】Laravel+Angularjs+D3打造可视化数据,RESTful+Ajax
  6. golang的并发
  7. [转]在 Windows Server 2012 上安装 IIS 8
  8. 理解sparse coding
  9. DHTMLX 前端框架 建立你的一个应用程序 教程(五)--添加一个表格Grid
  10. KeyEvent
  11. C语言的声明和定义
  12. JAVA词汇大全
  13. 四大组件之一---------activity的知识
  14. 笔记:XML-解析文档-XPath 定位信息
  15. digest-MD5认证
  16. 怎么动态生成js变量
  17. vimium使用
  18. MongoDB数据库(一):基本操作
  19. Android ble蓝牙问题
  20. react学习(四)之设置 css样式 篇

热门文章

  1. VBA清除Excelpassword保护,2003/2007/2010均适用
  2. Mysql 分别按月, 日为组group,进行统计排序order
  3. map的类型映射
  4. UNION ALL
  5. Java访问kafka的时候java.nio.channels.ClosedChannelException解决办法
  6. ARM编译空间属性(转)
  7. ExtJS 创建动态加载树
  8. Lucene学习总结之五:Lucene段合并(merge)过程分析
  9. jQuery 改变Form 指向的 Action
  10. [原]此程序专用来说明C++模板的用法