1038. Recover the Smallest Number (30)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287
 
我做题都是先用python秒一下,要是超时什么的就换C++了,这题我一看,就写了下面这一行代码:
print int(''.join(sorted(raw_input().split()[:], lambda s1, s2: cmp(s1+s2, s2+s1))))

是的只有一行!可惜最后一个test还是超时了。于是用C++再写:

#include <set>
#include <sstream>
#include <string>
#include <iostream>
using namespace std; class mstring : public string {
public:
inline bool operator<(const string &s) const {
string tmpa(*this);
tmpa.append(s);
string tmpb(s);
tmpb.append(*this);
return tmpa.compare(tmpb) < ;
}
}; int main() {
//#pragma warning(disable:4996)
//freopen("..\\advanced-pat-python\\test.txt", "r", stdin);
int N;
cin >> N;
set<mstring> nums;
mstring ms;
while (N--) {
cin >> ms;
nums.insert(ms);
}
mstring num;
set<mstring>::iterator it = nums.begin();
while (it!=nums.end()) {
num += *(it++);
}
while (!num.empty() && *num.begin()=='') {
num.erase(num.begin());
}
if (num.empty()) {
num += '';
}
cout << num << endl;
}

总体来说还是较为简单的,但是没有Python那么爽的一行解决掉了。Python真是神奇的语言啊。

最新文章

  1. Bash 中的 $0 在什么时候不是 argv[0]
  2. 二进制打印与逆序_C语言(转)
  3. 有关OpenCV1.0中GUI命令的几个函数学习总结
  4. SSD: Single Shot MultiBox Detector
  5. 【设计模式 - 7】之过滤器模式(Filter)
  6. windbg vmware win7联机调试环境搭建
  7. 推荐一些iOS博客
  8. C++ gui程序附加dos输出窗口
  9. 王之泰201771010131《面向对象程序设计(java)》第十二周学习总结
  10. cron 配置
  11. fcn+caffe+voc2012实验记录
  12. 第一章 Hyper-V 2012 R2角色部署
  13. Python - mouse clicks and keystrokes on a background window
  14. Activity横竖屏切换时 一些数据的保存
  15. Java SE学习【一】
  16. tensorflow1.12 cuda10 cudnn7
  17. tomcat如何利用waf进行防护
  18. LambdaMART简介——基于Ranklib源码(二 Regression Tree训练)
  19. 深入CSS属性(九):z-index
  20. oracle常用cmd命令

热门文章

  1. Java集合Map接口与Map.Entry学习
  2. git reflog 和git log :no branch git 提交方式
  3. UIScrollView解决touchesBegan等方法不能触发的解方案
  4. ASP.NET 学习博客
  5. 野指针、NULL指针和void*
  6. JavaScript中的Function类型浅析
  7. Ollydbg 中断方法浅探
  8. easyui源码翻译1.32--Slider(滑动条)
  9. linux 和 ecos 内核线程创建/信号量/event等对比
  10. 告别山寨数据线:USB Type-C加密认证出炉