Sum It Up

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 1

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

Source

浙江工业大学第四届大学生程序设计竞赛
做练习的时候,纠结死啦!
当时我一直在想怎样判重,自己YY了一个hash函数 WA了。。。
网上的一种解法不需要判重,剪枝就可以了。按照那个思路我重新敲了一下。
code1: (dfs+剪枝)
poj:
Accepted 388K 0MS G++ 930B
#include <stdio.h>
#include <string.h> int a[15];
int p[15];
int vis[15];
int t, n, flag; void dfs(int k, int sum) {
int i;
if(k>n || sum<0) return ;
if(sum==0) {
flag = 1;
for(i=0; i<k-1; i++)
printf("%d+",p[i]);
printf("%d\n",p[i]);
return ;
}
for(i=k; i<n; i++)
if(!vis[i]) {
if(sum-a[i]<0||(k>0&&a[i]>p[k-1])) continue;
vis[i] = 1;
p[k] = a[i];
dfs(k+1,sum-a[i]);
vis[i] = 0;
while(i+1<n&&a[i]==a[i+1]) i++; //搜索完毕后,若下一个搜索的数仍与当前相同,则寻找下一个不同的数进行搜索。{去重}
}
}
int main() {
int i;
while(scanf("%d%d",&t,&n),t+n) {
for(i=0; i<n; i++) scanf("%d",&a[i]);
i = 0;
while(i<n&&a[i]>t) i++;
printf("Sums of %d:\n",t);
flag = 0;
memset(vis,0,sizeof(vis));
dfs(i,t);
if(!flag) printf("NONE\n");
}
return 0;
}

code2:(用 set 去重:在POJ和ZOJ上提交全挂,不过hdu上能AC,呃呃呃~) 


HDU:
Accepted 1258 0MS 340K 1286 B G++

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <functional>
#include <vector>
#include <string>
#include <set>
using namespace std;
#define N 20
int t, n;
int a[N];
int list[N];
bool vis[N];
set<string> s;
bool flag; void dfs(int k, int sum) {
int i;
if(k>=n || sum<0) return;
if(sum==0) {
string str;
for(i=0; i<k; i++) {
str +=(list[i]/10) +'0';
str +=(list[i]%10) +'0';
}
if(s.find(str)==s.end()) {
s.insert(str);
flag = 1;
for(i=0; i<k-1; i++)
printf("%d+",list[i]);
printf("%d\n",list[i]);
}
return ;
}
for(i=k; i<n; i++)
if(!vis[i]&&(k==0||a[i]<=list[k-1])) {
vis[i] = 1;
list[k] = a[i];
dfs(k+1,sum-a[i]);
vis[i] = 0;
}
}
int main() {
int i;
while(scanf("%d%d",&t,&n),t+n) {
for(i=0; i<n; i++) {
scanf("%d",&a[i]);
}
memset(vis,0,sizeof(vis));
printf("Sums of %d:\n",t);
flag = false;
s.clear();
dfs(0,t);
if(!flag) printf("NONE\n");
}
return 0;
}


最新文章

  1. Python全栈开发【基础二】
  2. UE4 VR 模式全屏 4.13
  3. 关于java8 interface的default方法
  4. 有关stdint.h 文件
  5. HDU 1565 最大点权独立集
  6. HDU 4825 Xor Sum(经典01字典树+贪心)
  7. Jquery each 的跳出 break continue
  8. 问题-Delphi编译到最后Linking时总是出现与ntdll.dll有关的错误还有Fatal Error Out of memory错误
  9. git extrad_addons 部署说明
  10. PHP设计模式笔记八:原型模式 -- Rango韩老师 http://www.imooc.com/learn/236
  11. oc语言--protocol(协议)
  12. webpack优化之code splitting
  13. Linux 下软件的安装方法
  14. Spring-boot中@ConfigurationProperties,@Value,@PropertySource
  15. Navicat for MySQL连接mysql数据库时提示错误:Can&#39;t connect to MySQL server (10060)
  16. 在ASP.NET中使用KindEditor富文本编辑器
  17. 百万级数据下的mysql深度解析
  18. ValueError: too many values to unpack tensorflow
  19. DevExpress09、SimpleButton、CheckButton、DropDownButton、HScrollBar控件和VScrollBar控件
  20. db 文件 查看 打开 工具 db 中文 版 navicat 中文

热门文章

  1. 基于Qt下移动平台第三方接入-ShareSDK(新浪微博,微信朋友圈等分享登录)
  2. 用Response对象的write方法和&lt;%%&gt;及&lt;%=%&gt;输出同样效果的乘法表格
  3. 学习笔记,发QQ邮件
  4. china-pub
  5. 51cto运维培训课程
  6. 1104--DNA排序
  7. BZOJ 1631: [Usaco2007 Feb]Cow Party
  8. 同时支持多家云平台的管理工具HybridFox
  9. 【Eclipse Plugin】SonarQube 启动报错
  10. HDU 1969(二分法)