Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 48930   Accepted: 14130
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window
moves rightwards by one position. Following is an example: 

The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题意很好理解,就是对一个长度为n的数组,有一个大小为k的窗口不断向右移动,找出这个窗口中的最小值和最大值。

单调队列,如果是求最小值的话:满足两个条件,一个是队列中的元素从左至右 是从小到大的关系,保证从队头中提取出来的元素是最小值。求最大值则相反。

然后是队列的位置关系,要保证每一时刻队头的位置是最先淘汰的,其实这个不用去刻意保证,只要是从左扫到右,最先进来的元素肯定是最新鲜的元素,即后面位置的元素,只需满足head<=tail,就可以满足当p[head]在窗口外面时,只需head++的条件了。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std; #define maxn 1000005
int A[maxn];//存储数据
int Q[maxn];//队列
int P[maxn];//存储A[i]中的下标i
int Min[maxn];//输出最小
int Max[maxn];//输出最大
int n,k,num; void get_min()
{
int i;
int head=1,tail=0;
num=0;
for(i=0;i<k-1;i++)
{
while(head<=tail && Q[tail]>=A[i])
{
tail--;
}
Q[++tail]=A[i];
P[tail]=i;
//while(head<i-k+1&&head<=tail)
// head++;
}
for(;i<n;i++)
{
while(head<=tail &&Q[tail]>=A[i])
{
tail--;
}
Q[++tail]=A[i];
P[tail]=i;
while(P[head]<i-k+1&&head<=tail)
head++;
Min[num++]=Q[head];
}
} void get_max()
{
int i;
int head=1,tail=0;
num=0;
for(i=0;i<k-1;i++)
{
while(head<=tail && Q[tail]<= A[i])
{
tail--;
}
Q[++tail]=A[i];
P[tail]=i;
//while(head<i-k+1&&head<=tail)
// head++;
}
for(;i<n;i++)
{
while(head<=tail &&Q[tail] <= A[i])
{
tail--;
}
Q[++tail]=A[i];
P[tail]=i;
while(P[head]<i-k+1&&head<=tail)
head++;
Max[num++]=Q[head];
}
} int main()
{
//freopen("i.txt","r",stdin);
//freopen("o.txt","w",stdout); int i;
scanf("%d%d",&n,&k); for(i=0;i<n;i++)
{
scanf("%d",A+i);
}
get_min();
for(i=0;i<num;i++)
{
if(i==0)
{
printf("%d",Min[i]);
}
else
{
printf(" %d",Min[i]);
}
}
printf("\n"); get_max();
for(i=0;i<num;i++)
{
if(i==0)
{
printf("%d",Max[i]);
}
else
{
printf(" %d",Max[i]);
}
}
printf("\n");
//system("pause");
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. 关于touch事件对于性能的影响
  2. 【POJ各种模板汇总】(写在逆风省选前)(不断更新中)
  3. MySQL Profiling 的使用
  4. js细节
  5. hdu 1199 Color the Ball(离散化线段树)
  6. centos mysql 编译安装
  7. MCS-51单片机内部结构
  8. Android Intent的几种使用方法全面总结
  9. OTG驱动分析(一)
  10. oclazyload的尝试
  11. Web项目容器集成ActiveMQ &amp; SpringBoot整合ActiveMQ
  12. HDU1262-寻找素数对
  13. python 全栈开发,Day58(bootstrap组件,bootstrap JavaScript 插件,后台模板,图表插件,jQuery插件库,Animate.css,swiper,运行vue项目)
  14. FIN vs RST in TCP connections different
  15. CLE的使用笔记
  16. Tomcat设置虚拟目录的方法, 不修改server.xm
  17. jQuery ajax 添加头部参数跨域
  18. BZOJ1304: [CQOI2009]叶子的染色 树形dp
  19. Springboot日记——核心编码篇
  20. 2016级算法期末模拟练习赛-E.AlvinZH的青春记忆III

热门文章

  1. LCS(最长公共子序列)
  2. SRS源码—— Thread笔记
  3. Servlet对用户输入的数据进行读取
  4. 反射工具类【ReflectionUtils】
  5. 初探网络流:dinic/EK算法学习笔记
  6. 吴裕雄 Bootstrap 前端框架开发——Bootstrap 按钮:表示成功的动作
  7. json object string互转
  8. 二十三、java连接oracle数据库操作:jdbc
  9. 刷题55. Jump Game
  10. 5.8 Nginx 常用功能的配置