Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)

a2, a3, …, an, a1 (where m = 1)

a3, a4, …, an, a1, a2 (where m = 2)



an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10

1 3 6 9 0 8 5 7 4 2

Sample Output

16

Author

CHEN, Gaoli

Source

ZOJ Monthly, January 2003

Recommend

Ignatius.L | We have carefully selected several similar problems for you: 1166 1698 1540 1542 1255

看到题的第一眼还以为是动态逆序对,读完题后发现竟然是一道水题。

这道题想让我们求的是在不断改变元素的顺序之后所有逆序对的最小值。怎么做?首先我们知道在进行n" role="presentation" style="position: relative;">nn次轮换之后数列又变回去了,所以我们只需用一种高效的方法统计出每次轮换后数列逆序对的个数就行了。

怎么统计?

显然第一次逆序对直接上树状数组(线段树)求so" role="presentation" style="position: relative;">soso easy" role="presentation" style="position: relative;">easyeasy,那么之后的轮换呢?用n" role="presentation" style="position: relative;">nn次树状数组==gg" role="presentation" style="position: relative;">gggg,因此可以想到这样轮换有特殊的性质。没错就是这样。我们考虑当前队首的元素,这个元素从队首移到队尾的操作可以拆成队首弹出,队尾插入的操作,设上一次的逆序对数为sum" role="presentation" style="position: relative;">sumsum,那么这个元素从队首弹出显然会使sum" role="presentation" style="position: relative;">sumsum减少a1−1" role="presentation" style="position: relative;">a1−1a1−1,道理显然(a1" role="presentation" style="position: relative;">a1a1之后有a1−1" role="presentation" style="position: relative;">a1−1a1−1个数比它小),同理,这个元素从队尾插入会使sum" role="presentation" style="position: relative;">sumsum变大n−a1" role="presentation" style="position: relative;">n−a1n−a1(证明同理)。这样看来的话似乎一个循环比比大小就没了啊。

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 5005
using namespace std;
int n,bit[N],a[N],sum,ans;
inline int read(){
    int ans=0;
    char ch=getchar();
    while(!isdigit(ch))ch=getchar();
    while(isdigit(ch))ans=(ans<<3)+(ans<<1)+ch-'0',ch=getchar();
    return ans;
}
inline int lowbit(int x){return x&-x;}
inline void update(int x,int v){for(int i=x;i<=n;i+=lowbit(i))bit[i]+=v;}
inline int query(int x){int ans=0;for(int i=x;i;i-=lowbit(i))ans+=bit[i];return ans;}
int main(){
    while(~scanf("%d",&n)){
        sum=ans=0;
        memset(a,0,sizeof(a));
        memset(bit,0,sizeof(bit));
        for(int i=1;i<=n;++i){
            a[i]=read()+1;
            sum+=query(n)-query(a[i]);
            update(a[i],1);
        }
        ans=sum;
        for(int i=1;i<=n;++i)ans=min(ans,sum=sum-a[i]+1+n-a[i]);
        printf("%d\n",ans);
    }
    return 0;
}

最新文章

  1. python设计模式1:导言
  2. Mybatis 3.3.0 Log4j配置
  3. Super A^B mod C
  4. 苹果HomeKit如何牵动全国智能硬件格局
  5. ZLG_GUI配置与函数介绍
  6. UVa 11526 H(n)
  7. 【机器学习算法-python实现】svm支持向量机(1)—理论知识介绍
  8. 【随记】SQL Server连接字符串参数说明
  9. CENTOS elasticsearch plugin install:Failed: SSLException[java.security.ProviderException,解决
  10. C# 过滤SerialPort端口
  11. .net开源权限管理系统
  12. .apply()用法和call()的区别
  13. Android Gallery实现3D相册(附效果图+Demo源码)
  14. Springboot打包war
  15. spket插件安装并设置JQuery自动提示(转)
  16. Git Bash关键命令
  17. TED #05# How we can face the future without fear, together
  18. 第七周 ch04 课下测试补交
  19. Tkinter Cursors
  20. sed--行编辑器命令

热门文章

  1. Producer-consumer problem in Python
  2. null id in entry (don&#39;t flush the Session after an exception occurs)
  3. delphi实现两个目录路径的链接
  4. one by one 项目 part 4
  5. STC-51开发板-单片机控制数码管&amp;按键&amp;点阵综合操作
  6. ssh 设置反向代理
  7. linux下set命令的参数及用法
  8. Eureka 源码编译 部署
  9. ubuntu下搭建testlink
  10. Appuim学习路-Appuim介绍