As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
 

Sample Output:

2 4

题意:计算从救援队当前所在的城市到目标城市的通路数,途中经过的城市会有救援人员,求不同的通路上救援人员的最大值。

思路:(边)最短路问题+ (顶点)最大价值

AC 代码:

#include<iostream>
#include<algorithm>
using namespace std; int n, m, c1, c2;
int e[510][510], weight[510], dis[510], num[510], w[510];
bool visit[510];
const int inf = 99999999; int main() {
scanf("%d%d%d%d",&n, &m, &c1, &c2);
for(int i = 0; i < n; ++i) {
scanf("%d", &weight[i]);
}
fill(e[0], e[0] + 510 * 510, inf);
fill(dis, dis + 510, inf);
int a, b, c;
for (int i = 0; i < m; ++i) {
scanf("%d%d%d", &a, &b, &c);
e[a][b] = e[b][a] = c;
}
dis[c1] = 0;
w[c1] = weight[c1];
num[c1] = 1;
for (int i = 0; i < n; ++i) {
int u = -1, minn = inf;
for (int j = 0; j < n; ++j) {
if (visit[j] == false && dis[j] < minn) {
u = j;
minn = dis[j];
}
} if (u == -1) break;
visit[u] = true;
for (int v = 0; v < n; ++v) {
if (dis[u] + e[u][v] < dis[v]) {
dis[v] = dis[u] + e[u][v];
num[v] = num[u];
w[v] = w[u] + weight[v];
} else if (dis[u] + e[u][v] == dis[v]) {
num[v] = num[v] + num[u];
if (w[u] + weight[v] > w[v])
w[v] = w[u] + weight[v];
}
}
}
printf("%d %d", num[c2], w[c2]);
return 0;
}

2021-01-29

用DFS来做

python版:

# 信息读入
num_city, num_roads, cur_city, save_city = list(map(int, input().split()))
rescue = list(map(int, input().split()))
roads = [[] for _ in range(num_city)]
for _ in range(num_roads):
a = list(map(int, input().split()))
roads[a[0]].append((a[1], a[2]))
roads[a[1]].append((a[0], a[2])) # 定义几个变量
min_roads, max_rescue, min_distance = 0, 0, 99999
temp_distance, temp_rescue = 0, rescue[cur_city]
visited = {cur_city} def dfs(city):
global save_city, temp_distance, min_distance, temp_rescue, min_roads, max_rescue, visited
if city == save_city:
if temp_distance < min_distance:
min_distance = temp_distance
min_roads = 1
max_rescue = temp_rescue
elif temp_distance == min_distance:
min_roads += 1
if temp_rescue > max_rescue:
max_rescue = temp_rescue
return for next_city, distance in roads[city]:
if next_city not in visited:
visited.add(next_city)
temp_distance += distance
temp_rescue += rescue[next_city]
dfs(next_city)
temp_distance -= distance
temp_rescue -= rescue[next_city]
visited.remove(next_city) dfs(cur_city)
print(min_roads, max_rescue)

参考:

https://www.liuchuo.net/archives/2359

https://qsctech-sange.github.io/1003-Emergency.html#python3

最新文章

  1. 学习廖雪峰的git教程
  2. SQL Server数据库性能优化技巧
  3. github的使用步骤及体会
  4. 简单跳转到微信分享,基于libWeiChatSDK 和简单的自定义UIActivityViewController
  5. OpenCascade Matrix
  6. asp 实现域名转向
  7. WITH (NOLOCK)
  8. nyoj 84 阶乘的0
  9. [转]eclipse中使用maven插件的时候,运行run as maven build的时候报错
  10. Mysql--选择适合的引擎,提高操作速度
  11. .OpenWrt驱动程序Makefile的分析概述 、驱动程序代码参考、以及测试程序代码参考
  12. JQuery的方便之处——宽高设置、坐标值和滚动条+事件绑定机制
  13. Python3玩转儿 机器学习(1)
  14. 关于js-angularJS的路由传参
  15. plt.contour 与 plt.contourf
  16. C# 曲线控件 曲线绘制 实时曲线 多曲线控件 开发
  17. Retrofit 使用方法
  18. How to Pronounce the word BECAUSE
  19. 【SDOI2017】新生舞会
  20. Shader工具

热门文章

  1. docker封装nuxt项目使用jenkins发布
  2. EF获取数据库表名和列名
  3. 一些 html+css 细节
  4. POJ-1015(背包变形+输出路径)
  5. OpenGL中的坐标系统详细概括:包括Z缓冲
  6. Java跨平台原理与Java虚拟机(JVM)
  7. C# 应用 - 使用 HttpWebRequest 发起 Http 请求
  8. .NET 6 Preview 2 发布
  9. JAVA安装第一步JDK
  10. 题解 洛谷P1990 覆盖墙壁