【九度OJ】题目1445:How Many Tables 解题报告

标签(空格分隔): 九度OJ


原题地址:http://ac.jobdu.com/problem.php?pid=1445

题目描述:

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

输入:

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

输出:

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

样例输入:

2
5 3
1 2
2 3
4 5 5 1
2 5

样例输出:

2
4

Ways

根据上题的分析,只要有几个Tree[x]值为-1,那么就有单独几棵树,所以按照这个题的意思,就要有多少个桌子。所以这题和上题那个连通图没有区别。

另外,这个题目中的输入是有空行的,在C++中不用处理,因为会自动忽略掉这种输入。

#include<stdio.h>
#include<math.h> int Tree[1002]; int findRoot(int x) {
if (Tree[x] == -1) {
return x;
} else {
int temp = findRoot(Tree[x]);
Tree[x] = temp;
return temp;
}
} int main() {
int t;
scanf("%d", &t);
while (t-- != 0) {
int n, m;
scanf("%d%d", &n, &m);
for (int i = 1; i <= n; i++) {
Tree[i] = -1;
}
while (m-- != 0) {
int a, b;
scanf("%d%d", &a, &b);
int aRoot = findRoot(a);
int bRoot = findRoot(b);
if (aRoot != bRoot) {
Tree[aRoot] = bRoot;
}
}
int count = 0;
for (int i = 1; i <= n; i++) {
if (Tree[i] == -1) {
count++;
}
}
printf("%d\n", count);
} return 0;
}

Date

2017 年 3 月 10 日

最新文章

  1. django rest framework csrf failed csrf token missing or incorrect
  2. readonly=“readonly”与readonly=“true”
  3. HTML笔记(一)
  4. springmvc的3中路径风格
  5. 【转】bt协议的详细分析
  6. 基于特定领域国土GIS应用框架设计及应用
  7. 微信JS-SDK签名signature错误代码4029
  8. Netty4.0学习笔记系列之三:构建简单的http服务(转)
  9. 剑指offer-面试题22.栈的压入,弹出序列
  10. 微信小程序开发小记
  11. android使用百度地图最新sdk5.0后后代码混淆时,地图无法显示闪退问题
  12. Linux -- nginx
  13. 微服务之路由网关—Nginx
  14. django----多对多数据添加
  15. [转]pyCharm最新2018激活码
  16. 6. 合并排序数组 II
  17. Linux下TFTP服务的安装、配置和操作
  18. ERP合同管理流程查询(三十一)
  19. 「jQuery」获取元素的高度
  20. [Web 前端] ECMAScript5之StrictMode

热门文章

  1. Macbookpro vim操作键说明
  2. rabbit mq的一个实例,异步功能
  3. 详解getchar()函数与缓冲区
  4. SpringBoot Profiles 多环境配置及切换
  5. linux 实用指令文件目录类
  6. 日常Java 2021/10/30
  7. day01 前端bootstrap框架
  8. Spark基础:(三)Spark 键值对操作
  9. ES6必知,箭头函数与普通函数的区别。
  10. Servlet(1):Servlet介绍