Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat’s last theorem) was found only recently by Andrew Wiles.

Consider the following diophantine equation:

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)

Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:

1 / 5 + 1 / 20 = 1 / 4

1 / 6 + 1 / 12 = 1 / 4

1 / 8 + 1 / 8 = 1 / 4

Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?

Input

The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line.

Sample Input

2

4

1260

Sample Output

Scenario #1:

3

Scenario #2:

113

#include <bits/stdc++.h>
using namespace std;
const int MAX = 5e5 + 5;
int n;
long long ans;
void solve()
{
for (int i = 2; i * i <= n; i++)
{
int cnt = 0;
if (n % i == 0)
{
while (n % i == 0)
{
cnt++;
n /= i;
}
}
if (cnt)
ans *= (long long)(2 * cnt + 1);
}
} int main()
{
int T;
scanf("%d", &T);
for (int ca = 1; ca <= T; ca++)
{
ans = 1;
scanf("%d", &n);
solve();
if (n > 1)
ans *= 3LL;
printf("Scenario #%d:\n%lld\n\n", ca, (ans + 1)/2);
//这里是说题目中x,y y,x相等,应该除2向上取整
}
}

最新文章

  1. Ios 实现 滑动cell 伸缩的核心代码
  2. Python基础(二)之list
  3. HDU 1041 Computer Transformation (简单大数)
  4. XBox360自制系统的更新(Update)
  5. CSS Hacks 总结
  6. 费用流&amp;网络流模版
  7. Unable to resolve target &#39;android-XX&#39;解决办法
  8. Open-Falcon第七步安装报警模块(小米开源互联网企业级监控系统)
  9. 一文带你超详细了解Cookie
  10. PowerBI分析Exchange服務器IIS運行日誌
  11. JAVAScript:前端模块化开发
  12. Rifidi
  13. Unicode字符需要几个字节来存储?
  14. ZOJ 3593 One Person Game(ExGcd + 最优解)题解
  15. from…import 语句
  16. 一个简单的用python 实现系统登录的http接口服务实例
  17. spec 文件详解
  18. io整理
  19. C#数据库连接方法
  20. spring boot(1)-Hello World

热门文章

  1. Jquery的$.get(),$.post(),$.ajax(),$.getJSON()用法详细解读
  2. matplotlib IdentityTransform(原地变换)
  3. 对称加密算法在C#中的踩坑日常
  4. 【高并发】不废话,言简意赅介绍BlockingQueue
  5. 用Taro做个微信小程序Todo, 小白工作记录
  6. HPU第一次团队赛
  7. vue使用trackingjs
  8. [YII2] 3步发送邮件,有图有真相!
  9. Fiddler抓取抖音视频
  10. Liunx常用操作(二)-vim中删除命令