Toy Storage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3146   Accepted: 1798

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1
跟上一题差不多,只不过线的顺序成了乱序,需要进行排序。输出方式发生变化。
最好少用while()进行循环,会将循环次数的值最后变为0,在再次使用这个数值时容易遗忘。
#include<cstring >
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std; struct Point {
int x,y;
Point (){};
Point(int _x,int _y)
{
x=_x,y=_y;
}
Point operator -(const Point &b)const
{
return Point(x-b.x,y-b.y);
}
int operator *(const Point &b)const
{
return x*b.x+y*b.y;
}
int operator ^(const Point &b)const
{
return x*b.y-y*b.x;
}
}; struct Line{
Point s,e;
Line(){};
Line(Point _s,Point _e)
{
s=_s,e=_e;
}
}; int xmult(Point p0,Point p1,Point p2)
{
return (p1-p0)^(p2-p0);
} bool cmp(Line a,Line b)//按照线的第一个点的横坐标进行的排序(题干中线段不会交叉,所以随便选取坐标进行排序)
{
return a.s.x<b.s.x;
} const int MAXN=1050;
Line line[MAXN];
int ans[MAXN];
int sum[MAXN];
int main ()
{
int n,m,x1,y1,x2,y2;
while(cin>>n,n)
{
cin>>m>>x1>>y1>>x2>>y2;
int U,L;
for(int i=0;i<n;i++)
{
cin>>U>>L;
line[i]=Line(Point(U,y1),Point(L,y2));
}
line[n]=Line(Point(x2,y1),Point(x2,y2));//s上边点
sort(line,line+n+1,cmp);
int x,y;
Point p;
memset(ans,0,sizeof(ans));
memset(sum,0,sizeof(sum));
for(int i=0;i<m;i++)
{
cin>>x>>y;
p=Point(x,y);
int l=0,r=n;
while(l<r)
{
int mid=(l+r)/2;
if(xmult(p,line[mid].e,line[mid].s)>0)
r=mid;
else
l=mid+1;
}
ans[l]++;
}
for(int i=0;i<=n;i++)
sum[ans[i]]++;
cout<<"Box"<<endl;
for(int i=1;i<=m;i++)
if(sum[i]>0)
cout<<i<<": "<<sum[i]<<endl;
}
return 0;
}

最新文章

  1. String()与 toString()
  2. 【项目启动】 tomcat启动,项目无法启动,无法正常访问/项目可以启动,报错:java.lang.ClassNotFoundException: ContextLoaderListener
  3. JQuery上传插件uploadify优化
  4. qemu-img convert -c -O qcow2 source.raw aim.qcow2
  5. struts1配置文件之input
  6. C++小知识之Vector排序
  7. Visual Studio Team Services使用教程--默认团队checkin权限修改
  8. java Socket实现简单在线聊天(三)
  9. poj 2955&quot;Brackets&quot;(区间DP)
  10. Spring事务说明与自实现
  11. 6-6 小球下落 uva679
  12. CorelCAD for Mac(绘图设计软件)破解版安装
  13. awesome-workflow-engines
  14. InfluxDB 常用命令
  15. centos 7 linux x64
  16. Docker 技巧:删除 Docker 所有镜像
  17. Shell编程-05-Shell中条件测试与比较
  18. 剑指offer四十五之扑克牌顺子(序列是否连续)
  19. 题解 P1967 【货车运输】
  20. MsSqlserver 查看锁表与解锁

热门文章

  1. 【SpringBoot1.x】SpringBoot1.x 消息
  2. Python模块化编程与装饰器
  3. Docker构建Python Web环境
  4. 如何构建一个多人(.io) Web 游戏,第 2 部分
  5. kubernets之节点和网络的安全保障策略
  6. 用 CSS background 实现刻度线的呈现
  7. 把vscode打造成技术写作神器
  8. powershell中的cmdlet命令
  9. 转 10 jmeter之动态关联
  10. 线上一次大量 CLOSE_WAIT 复盘