Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

首先看看样例是怎么变成1123123111的

  1. 1
  2. 11
  3. 12
  4. 1121
  5. 122111
  6. 112213
  7. 12221131
  8. 1123123111

本题要点:

  1. string 只能用 cin cout 输入输出,不能使用 scanf 与 printf
  2. t = t +…与 t+=… 后者效率较高
  3. to_string()将数字转为字符串
#include <iostream>
#include <string>

using namespace std;

int main() {
    int N, j;
    string s;
    cin >> s >> N;
    for(int cnt = 1;cnt < N; cnt++){
        string t;
        for(int i = 0; i < s.length(); i = j){
            for(j = i; j < s.length() && s[j] == s[i]; j++);
            t += s[i] + to_string(j - i); //如果使用t=t+...会超时
        }
        s = t;
    }
    cout << s;
    return 0;
}

最新文章

  1. 解决maven下载jar慢的问题(如何更换Maven下载源)
  2. chrome浏览器root用户运行
  3. rsync错误日志
  4. yii 多模板
  5. C Primer Plus之结构和其他数据形式
  6. Hibernate笔记——关联关系配置(一对多、一对一和多对多)
  7. 杭电ACM2097--Sky数
  8. Android 控制ScrollView滚动到底部
  9. CSS3中的transform
  10. Xamarin改写安卓Residemenu控件
  11. 黑马程序员_Java_String
  12. PHP内核学习(一)SAPI
  13. temp-mootools简单语法
  14. Web.xml详解分析
  15. div放在li标签中,无法撑开li标签的问题
  16. YUM仓库配置
  17. gearman kubernetes 运行
  18. ucore-lab1-练习4report
  19. Web API(一);Restful架构
  20. 19重定向管道与popen模型

热门文章

  1. 群论&amp;Polya计数
  2. idea导入新项目后右键main方法没有Run xxx.main()
  3. SFINAE 与 type_traits
  4. SQL笔记整理
  5. zookeeper基础教程
  6. markdown使用介绍
  7. maven工具引入lib下的jar文件
  8. 19 01 15 django 数据库设计模型 管理站点 注意:在引入外键在django 2以上改版
  9. Centos7 死循环登录问题
  10. SpringCloud学习之手把手教你用IDEA搭建入门项目(三)