题目链接:

pid=1312" target="_blank">HDU1312 / POJ1979 / ZOJ2165 Red and Black(红与黑)

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9902    Accepted Submission(s): 6158

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.



Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.



There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.



'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 
 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 
Sample Output
45
59
6
13
 
Source

题意:

有一个长方形的房间布满了正方形的瓷砖,瓷砖要么红色要么黑色。一男子站在当中一块黑色瓷砖上,可向上下左右四个方向移动。但不能移动到红色瓷砖上,问他可到达的黑色瓷砖数量。

分析:

DFS搜索。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std; int dir[4][2] = {{-1, 0},{0, 1},{1, 0},{0, -1}};
int cnt, W, H;
char mp[21][21];
bool vis[21][21];
void dfs(int x, int y)
{
vis[x][y] = true;
for(int i = 0; i < 4; i++)
{
int tx = x + dir[i][0];
int ty = y + dir[i][1];
if(tx >= 1 && tx <= H && ty >= 1 && ty <= W && !vis[tx][ty] && mp[tx][ty] == '.')
{
cnt++;
dfs(tx, ty);
}
}
}
int main()
{
char c;
int x, y;
while(scanf("%d%d", &W, &H), W, H)
{
scanf("%c", &c);
for(int i = 1; i <= H; i++)
{
for(int j = 1; j <= W; j++)
{
scanf("%c", &mp[i][j]);
if(mp[i][j] == '@')
{
x = i;
y = j;
}
}
scanf("%c", &c);
}
cnt = 1;
memset(vis, false, sizeof(vis));
dfs(x, y);
printf("%d\n", cnt);
}
return 0;
}

最新文章

  1. NSRunLoop的进一步理解
  2. Hibernate的检索方式
  3. Windows的bat脚本中for循环
  4. U盘安装中标麒麟服务器操作系统 一 (NeoKylin 6.5)
  5. NodeJS学习笔记之Connect中间件模块(一)
  6. 通过自定义属性存储数据实现输入框获得焦点与失去焦点改变value值
  7. 转 SQL Union和SQL Union All两者用法区别效率以及与order by 和 group by配合问题
  8. matlab的调试方法
  9. 基于Raft构建弹性伸缩的存储系统的一些实践
  10. 【高斯消元】Poj 1222:EXTENDED LIGHTS OUT
  11. PID教程
  12. 【C#】Send data between applications
  13. hdu1698线段树的区间更新区间查询
  14. Android的init过程:init.rc解析流程
  15. Angular2 ^ 资源链接
  16. android开发要避免的那些坑
  17. 解决spring 用@Value注入配置时候出现中文乱码问题
  18. 走近HTTP协议之一 基本网络概念与理解
  19. vue 使用element-ui upload文件上传之后怎么清空
  20. Oauth2.0(二):开放平台

热门文章

  1. 谷歌浏览器(chrome) —— 扩展应用程序
  2. raspberry-常用命令
  3. 关于H5优化的一些问题
  4. 微信小程序怎么开发(小程序开发文档)
  5. 利用JavaScript制作简易日历
  6. AVD的Hardware选项
  7. MSSQL_20160719_在作业步骤中使用sp_send_dbmail遇到的问题
  8. ERROR 1062 (23000): Duplicate entry for key &#39;PRIMARY&#39;
  9. Docker-compose Setup for Self-hosting Development &amp; Deployment Tools
  10. python网络编程part1