Walking Ant


Time Limit: 2 Seconds     
Memory Limit: 65536 KB


Ants are quite diligent. They sometimes build their nests beneath flagstones.

Here, an ant is walking in a rectangular area tiled with square flagstones, seeking the only hole leading to her nest.

The ant takes exactly one second to move from one flagstone to another. That is, if the ant is on the flagstone with coordinates (x,y) at time t, she will be on one of the five flagstones with the following coordinates at time t+1:

(x, y), (x+1, y), (x-1, y), (x, y+1), (x, y-1).

The ant cannot go out of the rectangular area. The ant can visit the same flagstone more than once.

Insects are easy to starve. The ant has to go back to her nest without starving. Physical strength of the ant is expressed by the unit "HP". Initially, the ant has the strength of 6 HP. Every second, she loses 1 HP. When the ant arrives at a flagstone with
some food on it, she eats a small piece of the food there, and recovers her strength to the maximum value, i.e., 6 HP, without taking any time. The food is plenty enough, and she can eat it as many times as she wants.

When the ant's strength gets down to 0 HP, she dies and will not move anymore. If the ant's strength gets down to 0 HP at the moment she moves to a flagstone, she does not effectively reach the flagstone: even if some food is on it, she cannot eat it; even
if the hole is on that stone, she has to die at the entrance of her home.

If there is a puddle on a flagstone, the ant cannot move there.

Your job is to write a program which computes the minimum possible time for the ant to reach the hole with positive strength from her start position, if ever possible.

Input



The input consists of multiple maps, each representing the size and the arrangement of the rectangular area. A map is given in the following format.

w h

d11 d12 d13 ... d1w

d21 d22 d23 ... d2w

...

dh1 dh2 dh3 ... dhw

The integers w and h are the numbers of flagstones in the x- and y-directions, respectively. w and h are less than or equal to 8. The integer dyx represents the state of the flagstone with coordinates (x, y) as follows.

0: There is a puddle on the flagstone, and the ant cannot move there.

1, 2: Nothing exists on the flagstone, and the ant can move there. `2' indicates where the ant initially stands.

3: The hole to the nest is on the flagstone.

4: Some food is on the flagstone.

There is one and only one flagstone with a hole. Not more than five flagstones have food on them.

The end of the input is indicated by a line with two zeros.

Integer numbers in an input line are separated by at least one space character.

Output



For each map in the input, your program should output one line containing one integer representing the minimum time. If the ant cannot return to her nest, your program should output -1 instead of the minimum time.

Sample Input

3 3

2 1 1

1 1 0

1 1 3

8 4

2 1 1 0 1 1 1 0

1 0 4 1 1 0 4 1

1 0 0 0 0 0 0 1

1 1 1 4 1 1 1 3

8 5

1 2 1 1 1 1 1 4

1 0 0 0 1 0 0 1

1 4 1 0 1 1 0 1

1 0 0 0 0 3 0 1

1 1 4 1 1 1 1 1

8 7

1 2 1 1 1 1 1 1

1 1 1 1 1 1 1 4

1 1 1 1 1 1 1 1

1 1 1 1 4 1 1 1

4 1 1 1 1 1 1 1

1 1 1 1 1 1 1 1

1 1 1 1 1 1 1 3

8 8

1 1 1 1 1 1 1 1

1 1 1 1 1 1 1 1

1 1 1 1 1 1 1 1

1 4 4 1 1 1 1 1

1 4 4 2 1 1 0 0

1 1 0 0 0 0 0 3

1 1 0 4 1 1 1 1

1 1 1 1 1 1 1 1

8 8

1 1 1 1 1 1 1 1

1 1 2 1 1 1 1 1

1 1 4 4 4 1 1 1

1 1 1 4 4 1 0 1

1 1 1 1 1 1 0 1

1 1 1 1 1 1 0 3

1 1 1 1 1 1 1 1

1 1 1 1 1 1 1 1

0 0

Sample Output

4

-1

13

20

-1

-1

一仅仅蚂蚁在一个迷宫里,1能够走。0表示墙。2起始位置,3出口,4食物。初始体力为6,每走一步就消耗体力1

假设体力消耗完不到出口就输出-1。吃到食物体力恢复到6。注意一点,当它体力变为1时。到下一步可以到有

食物的点,但却不能吃食物,由于这时候体力已经到0了。即使有食物也不能补充体力,假设这个点是出口也不能出去。另

外吃了食物后要把那个

点的值变为1。由于有可能再走这个点。

bfs,注意凝视地方。错了好几次

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define M 1000
int n,m,sx,sy,ex,ey;
int mp[M][M];
int dre[4][2]={-1,0,1,0,0,-1,0,1};
struct node{
int x,y,hp,step;
}s,v;
int bfs(){
queue <node> Q;
v.x=sx; v.y=sy; v.hp=6; v.step=0;
Q.push(v);
while(!Q.empty()){
s=Q.front();
Q.pop();
for(int i=0;i<4;i++){
v.x=s.x+dre[i][0];
v.y=s.y+dre[i][1];
v.hp=s.hp-1;
v.step=s.step+1;
if(v.hp==0) continue;//无论有没有食物,搜索其它点 
if(mp[v.x][v.y]==3) return v.step;
if(v.x<1||v.y<1||v.x>n||v.y>m||mp[v.x][v.y]==0)
continue;
if(mp[v.x][v.y]==4){
v.hp=6;
mp[v.x][v.y]=1;//这一定要变为1。由于每一个点不止能走一次
}
Q.push(v);
}
}
return -1;
}
int main(){
int i,j;
while(~scanf("%d%d",&m,&n),n+m){
for(i=1;i<=n;i++){
for(j=1;j<=m;j++){
scanf("%d",&mp[i][j]);
if(mp[i][j]==2){
sx=i; sy=j;
}
if(mp[i][j]==3){
ex=i; ey=j;
}
}
}
printf("%d\n",bfs());
}
return 0;
}

最新文章

  1. [分享] 封装工具ES4配置文件解释
  2. Unity 几种碰撞模式
  3. jenkins 把包传到远程服务器上
  4. 发现不错的cache系统Cache Manager Documentation
  5. Fenix – 基于 Node.js 的桌面静态 Web 服务器
  6. 【bzoj1004】[HNOI2008]Cards
  7. lintcode:线段树的构造
  8. 英语之idiom
  9. poj 3026 (最小生成树)
  10. JavaEE:Tomcat服务器常用配置和HTTP简介
  11. Java与算法之(5) - 老鼠走迷宫(深度优先算法)
  12. C语言程序设计第四次作业——选择结构(二)
  13. SQLServer的三种Recovery Model
  14. 在Linux下开发多语言软件(gettext解决方案)
  15. 部署MySQL5.7时的权限问题
  16. Linux学习之常用文件处理命令(一)
  17. 随手记录一下 Vue 下来框搜索 select2 封装成vue
  18. 使用JavaScript动态更改CSS样式
  19. &lt;转&gt;Logistic回归总结
  20. 健康类App原型制作分享-Mindmate

热门文章

  1. WCF学习笔记(1)-一个完整的例子
  2. js this 和 event 的区别
  3. Android ViewPager+HorizontalScrollView实现标题栏滑动(腾讯新闻)
  4. Selenium示例集锦--常见元素识别方法、下拉框、文本域及富文本框、鼠标操作、一组元素定位、弹窗、多窗口处理、JS、frame、文件上传和下载
  5. oracle插入字符串数据时,字符串中有&#39;单引号
  6. Stanford coursera Andrew Ng 机器学习课程第四周总结(附Exercise 3)
  7. (转)Hibernate框架基础——一对多关联关系映射
  8. 【原】Mysql存储关联数组
  9. Vue组件传值方法调用
  10. .net core 中简单封装Dapper.Extensions 并使用sqlsuger自动生成实体类