Problem Description

Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the rope to the bridge, the other end of the rope to his body and jump off the bridge. At the moment he reaches the ground, he will cut the rope, jump into his car and be gone.

Unfortunately, he had not had
enough time to calculate whether the bungee rope has the right length, so it is
not clear at all what is going to happen when he jumps off the bridge. There are
three possible scenarios:
The rope is too short (or too strong), and James
Bond will never reach the ground.
The rope is too long (or too weak), and
James Bond will be going too fast when he touches the ground. Even for a special
agent, this can be very dangerous. You may assume that if he collides at a speed
of more than 10 m/s, he will not survive the impact.
The rope's length and
strength are good. James Bond touches the ground at a comfortable speed and can
escape.
As his employer, you would like to know whether James Bond survives
or whether you should place a job ad for the soon-to-be vacant position in the
local newspaper. Your physicists claim that:
The force with which James is
pulled towards the earth is
9.81 * w,
where w is his weight in kilograms
and 9.81 is the Earth acceleration in meters over squared seconds.
Mr. Bond
falls freely until the rope tautens. Then the force with which the bungee rope
pulls him back into the sky depends on the current length of the rope and is

k * Δl,
where Δl is the difference between the rope's current length and
its nominal, unexpanded length, and k is a rope-specific constant.
Given the
rope's strength k, the nominal length of the rope l in meters, the height of the
bridge s in meters, and James Bond's body weight w, you have to determine what
is going to happen to our hero. For all your calculations, you may assume that
James Bond is a point at the end of the rope and the rope has no mass. You may
further assume that k, l, s, and w are non-negative and that s <
200.

The input contains several test cases, one test case per line. Each
test case consists of four floating-point numbers (k, l, s, and w) that describe
the situation. Depending on what is going to happen, your program must print
"Stuck in the air.", "Killed by the impact.", or "James Bond survives.". Input
is terminated by a line containing four 0s, this line should not be processed.

 

Sample Input

350 20 30 75
375 20 30 75
400 20 30 75
425 20 30 75
450 20 30 75
400 20 30 50
400 20 30 80
400 20 30 85
0 0 0 0
 

Sample Output

Killed by the impact.
James Bond survives.
James Bond survives.
James Bond survives.
Stuck in the air.
Stuck in the air.
James Bond survives.
Killed by the impact.
 
物理题,求一个人从桥上用绳子跳下的三种状态,绳子有弹性,劲度系数为k,若人落地的速度大于10就会摔死。
思路:
  先求出人从桥到地的重力势能Eg,速度为10的动能Ev,绳拉到地( 绳不一定能到地面,假设到地 ) 的弹性势能Ek,先比较绳的长度和桥的高度,若绳长大于桥高,判断Eg和Ev的大小;
若绳长小于桥高,比较Eg和Ek的大小,Eg < Ek说明人不会落地,否则比较Eg-Ek和Ev的大小。
 /*
k 绳子劲度系数
l 绳长
s 桥的高度
w 体重
*/
#include<cstdio>
#define g 9.81
int main()
{
double k,l,s,w;
double Eg,Ek,Ev;
while(scanf("%lf %lf %lf %lf",&k,&l,&s,&w)&&(k+l+s+w))
{
Eg=w*g*s;
Ev=*w/;
Ek=k*(s-l)*(s-l)/;
if(l >= s)
{
if(Eg <= Ev)
printf("James Bond survives.\n");
else
printf("Killed by the impact.\n");
}
else
{
if(Eg < Ek)
printf("Stuck in the air.\n");
else if(Eg-Ek <= Ev)
printf("James Bond survives.\n");
else
printf("Killed by the impact.\n");
} } }

最新文章

  1. cesiumjs开发实践之坐标转换
  2. Java的常用对象①②
  3. Scalaz(21)-类型例证:Liskov and Leibniz - type evidence
  4. SHA-2 Certificate Signing Request
  5. 多语言本地化开发Localized
  6. 浅谈MySQL索引背后的数据结构及算法(转载)
  7. 数学之路(3)-机器学习(3)-机器学习算法-PCA
  8. Request.getparameternames 获取form表单里面所有的请求参数 。 返回一个Enumeration类型的枚举.
  9. Java 对象在堆中的内存结构
  10. Python3开发过程常见的异常(最近更新:2019-04-26)
  11. Python数据可视化-seaborn库之countplot
  12. js对象跟数组多层嵌套,检测没有此数据就添加有则不添加以及超过限制条件删除操作
  13. Spark1.0.0 源码编译和部署包生成
  14. 傻瓜式搭建私人网络硬盘——owncloud安装指南
  15. OSGI企业应用开发(十一)Bundle资源获取途径
  16. 【学习笔记】--- 老男孩学Python,day18 面向对象------继承
  17. mysql添加federated引擎实现dblink远程表访问
  18. UsernameToken 【转】
  19. 题解 P3153 【[CQOI2009]跳舞】
  20. 【占位】HihoCoder1317 跳舞链

热门文章

  1. Core 事件总
  2. Joda-Time 的 DateTimeFormat 问题
  3. Oracle更新表字段时内容中含有特殊字符&amp;的解决方法
  4. 读取jar包内的文件内容
  5. CF1088D Ehab and another another xor problem
  6. 用Node+wechaty写一个爬虫脚本每天定时给女(男)朋友发微信暖心话
  7. 文件系统结构-《循序渐进linux》
  8. Azure 门户使用概览
  9. UVA12906 Maximum Score (组合)
  10. UVA 211 The Domino Effect 多米诺效应 (回溯)