Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2982    Accepted Submission(s): 2202
Problem Description
Now, here is a fuction:

  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)

Can you find the minimum value when x is between 0 and 100.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 
Sample Input
2
100
200
 
Sample Output
-74.4291
-178.8534
 

#include <stdio.h>
#include <math.h>
double y, ans; double f(double x){
return 6 * pow(x, 7) + 8 * pow(x, 6) +
7 * pow(x, 3) + 5 * x * x - y * x;
} double ff(double x){ //求导
return 42 * pow(x, 6) + 48 * pow(x, 5)
+ 21 * x * x + 10 * x - y;
} int main(){
int n;
scanf("%d", &n);
while(n--){
scanf("%lf", &y);
if(ff(0) >= 0) ans = f(0);
else if(ff(100) <= 0) ans = f(100);
else{
double left = 0, right = 100, mid;
while(left + 1e-8 < right){
mid = (left + right) / 2;
if(ff(mid) > 0) right = mid;
else if(ff(mid) < 0) left = mid;
else break;
}
ans = f(mid);
}
printf("%.4lf\n", ans);
}
return 0;
}

最新文章

  1. Nginx上传文件返回413的解决
  2. iOS开发 GET、POST请求方法(NSURLConnection篇)
  3. [XAF] Simplifying integration of custom controls bound to data from XAF application database
  4. 解决AndroidStudio升级版本后恢复初始化设置的问题
  5. Idea反向生成JavaBean
  6. java中数据类型转换
  7. Effective Java 27 Favor generic methods
  8. javascript与服务器2
  9. Java主要有那几种文件类型,各自作用
  10. Hibernate入门学习(一)
  11. ln: creating hard link 问题
  12. thinkPHP 无法create,无法插入数据,提示非法数据对象
  13. Asp.Net复习篇之Asp.Net生命周期与Asp.Net页的生命周期
  14. 躲避球游戏ios源码
  15. WinForm 实现登录,验证成功,关闭登录界面,显示主界面
  16. python 列表 字典 读写文件:pickle模块的基本使用
  17. 寒哥细谈之AutoLayout全解
  18. 反调试——jmp到那个地址
  19. android系统添加预置APP(so库自动释放)
  20. WSGI 的简单理解

热门文章

  1. 【BZOJ1939】[Croatian2010] Zuma(动态规划)
  2. CF 436D 最小生成树
  3. Spring思维课程导图——bean属性的设置
  4. 357 Count Numbers with Unique Digits 计算各个位数不同的数字个数
  5. 【转】Linux下使用locale命令设置语言环境
  6. 研磨JavaScript系列(三):函数的魔力
  7. Maven 学习(1)
  8. [转]STL之deque容器详解
  9. PHP开发之旅-验证码功能实现
  10. JS高级——词法作用域