According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. At each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10

3 1 2 8 7 5 9 4 6 0

1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort

1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10

3 1 2 8 7 5 9 4 6 0

6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort

5 4 3 1 0 2 6 7 8 9

#include<iostream>
using namespace std;
int main(){
int N; cin>>N;
int i,j,flag=1,tag=0;
int num0[N],num1[N];
for(i=0;i<N;i++)
cin>>num0[i];
for(i=0;i<N;i++)
cin>>num1[i];
for(i=0;i<N-1;i++)
if(num1[i]>num1[i+1]) break;
for(j=i+1;j<N;j++)
if(num1[j]!=num0[j]) flag=0;
if(flag==0){
cout<<"Heap Sort"<<endl;
for(j=1;j<N;j++)
if(num1[(j-1)/2]<num1[j]) break;
j=j-1;
int temp=num1[j];
num1[j]=num1[0];
num1[0]=temp;
j--;
int parent,child;
temp=num1[0];
for(parent=0;2*parent+1<=j;parent=child){
child=parent*2+1;
if(child<j&&num1[child+1]>num1[child])
child++;
if(num1[child]>temp)
num1[parent]=num1[child];
else
break;
}
num1[parent]=temp;
}
else{
cout<<"Insertion Sort"<<endl;
int temp=num1[i+1];
for(i=i+1;i>0;i--)
if(num1[i-1]>temp) num1[i]=num1[i-1];
else break;
num1[i]=temp;
}
for(int k=0;k<N;k++)
if(tag++==0) cout<<num1[k];
else cout<<" "<<num1[k];
return 0;
}

最新文章

  1. js—模糊查询
  2. iOS 将一串字符里面的某个字符全部标志出来
  3. javascript无缝滚动示例
  4. QQ拼音在中文输入下默认英文标点
  5. JS和CSS的多浏览器兼容(3)
  6. java用freemarker导出数据到word(含多图片)
  7. 关键词权重计算算法:TF-IDF
  8. pod update或者pod install很慢
  9. Python新手学习基础之运算符——赋值与逻辑运算
  10. Linux UGO和ACL权限管理
  11. javascript模式——Facade
  12. Python之路:Python 基础(二)
  13. [算法题] Search in Rotated Sorted Array
  14. 1.1python解决数学建模之席位分配问题
  15. mqtt------ mosca服务器端参数简介
  16. Java 运行时常量池
  17. ubuntu 下 rvm 卸载和重装
  18. OSGI企业应用开发(七)细说Blueprint &amp; Gemini Blueprint(二)
  19. PHP SNOOPY采集类 总结
  20. express入门学习(一)

热门文章

  1. python 数据描述字符串转整数
  2. java 四种实现延迟加载的方法
  3. Java 并发编程(二)对象的公布逸出和线程封闭
  4. 42.extjs Combobox动态加载数据问题,mode:local 还是remote
  5. Coursera Algorithms week3 快速排序 练习测验: Selection in two sorted arrays(从两个有序数组中寻找第K大元素)
  6. 一、Linux文件权限与目录配置
  7. 虚拟化技术概要之VMM结构
  8. bzoj1088扫雷(搜索)
  9. 关于网页的自适应问题一---Media Query(媒介查询)
  10. Oh,mygoddess