Binary Numbers

点我

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3820    Accepted Submission(s):
2321

Problem Description
Given a positive integer n, find the positions of all
1's in its binary representation. The position of the least significant bit is
0.

Example

The positions of 1's in the binary representation
of 13 are 0, 2, 3.

Task

Write a program which for each data
set:

reads a positive integer n,

computes the positions of 1's in
the binary representation of n,

writes the result.

 
Input
The first line of the input contains exactly one
positive integer d equal to the number of data sets, 1 <= d <= 10. The
data sets follow.

Each data set consists of exactly one line containing
exactly one integer n, 1 <= n <= 10^6.

 
Output
The output should consists of exactly d lines, one line
for each data set.

Line i, 1 <= i <= d, should contain increasing
sequence of integers separated by single spaces - the positions of 1's in the
binary representation of the i-th input number.

 
Sample Input
1
13
 
Sample Output
0 2 3
 #include <iostream>
using namespace std;
int main(int argc, char const *argv[])
{
int T;
cin>>T;
while(T--)
{
int n,i=,j,k,flag=;
cin>>n;
while(n)
{
if(n%==)
{
cout<<i;
if(n>=)
cout<<' ';
}
i++;
n/=;
}
cout<<endl;
}
}
 
 

最新文章

  1. 7.Java中的字符串
  2. 控制器(Controller) &ndash; ASP.NET MVC 4 系列
  3. nginx location 的配置
  4. 双方都在线,qq总是离线发文件
  5. Linux 上的游戏 Supertuxkart
  6. BZOJ 3265 志愿者招募增强版 单
  7. OC - 15.NSURLSession与NSURLSessionTask
  8. POJ1797 Heavy Transportation 【Dijkstra】
  9. sql查询表说明
  10. PostgreSql的Explain命令详解
  11. Android 视频通信,低延时解决方案
  12. [Educational Round 59][Codeforces 1107G. Vasya and Maximum Profit]
  13. Where is the Marble? (寻找大理石上的数字)
  14. 通过iptables添加QoS标记
  15. UE4动画及相关物理的更新顺序图
  16. DbProviderFactory
  17. [翻译]高并发框架 LMAX Disruptor 介绍
  18. 高可用Hadoop平台-实战尾声篇
  19. python+Django框架运用(三)
  20. React 入门学习笔记1

热门文章

  1. innobackupex 使用说明
  2. [转]让Sublime Text2支持浏览器中预览
  3. javascript之window对象
  4. gcc的stdcall扩展
  5. Path Sum 解答
  6. LeeCode-Remove Linked List Elements
  7. Unity扩展 四种Menu的区别
  8. js埋点(转载)
  9. HDUJ 1754 I Hate It
  10. Expected authority at index 7: hdfs://