Problem Description

Calculate S(n).

S(n)=1^3+2^3 +3^3 +……+n^3 .

Input

Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output

For each case, output the last four dights of S(N) in one line.

Sample Input

1

2

Sample Output

0001

0009

题意是:给一个数n,求S(n)=1^3+2^3 +3^3 +……+n^3 .输出最后4位数字,不足4位的补零输出。

如果没找出周期会超时的。

我找到的是以10000为周期。

import java.util.Scanner;
//10000为周期
public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
int n = sc.nextInt();
int sum =0;
int t;
n = n%10000;
for(int i=1;i<=n;i++){
sum = ((sum)%10000+(((i)%10000)*((i)%10000))%10000*((i)%10000))%10000;
}
if(sum<10){
System.out.println("000"+sum);
}else if(sum<100){
System.out.println("00"+sum);
}else if(sum<1000){
System.out.println("0"+sum);
}else{
System.out.println(sum);
}
}
}
}

最新文章

  1. Android开发学习之路-该怎么学Android(Service和Activity通信为例)
  2. 关于baseflight cleanflight naze32不能解锁的办法
  3. Linux服务器使用命令操作MySQL插入数据乱码问题
  4. 2013 ACM/ICPC 长沙现场赛 C题 - Collision (ZOJ 3728)
  5. 利用ACE 自己实现的线程池
  6. leetcode面试准备:Valid Anagram
  7. mysql 的 decimal类型
  8. CentOS7 vs centos6
  9. Common Git command and mean (Windows)
  10. jQuery 3.0最终版发布,十大新特性眼前一亮
  11. yii2 部分很实用的代码
  12. Linux error numbers
  13. [daily] docker
  14. 【题解】Luogu UVA1411 Ants
  15. LeetCode--401--二进制手表
  16. 深度图像配准(Registration)原理
  17. &lt;转载&gt; js 闭包
  18. Antlr4 入门
  19. ardunio 实现RS485通讯-下位机
  20. vue+vux 父组件控制子组件弹层

热门文章

  1. 亲测 安装 mysql5.5 64位
  2. 实例化讲解 RunLoop
  3. JDK5-枚举
  4. css中var函数
  5. android高效ORM数据库框架greenDao使用
  6. 我的github今天大手笔分享,welcome——fork
  7. Android开源项目 Universal imageloader 源码研究之项目框架
  8. Rechability的简单使用
  9. IIS 配置问题解决
  10. wariging for you oh~