Boring count

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 787 Accepted Submission(s): 325

Problem Description

You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.

Input

In the first line there is an integer T , indicates the number of test cases.

For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]

1<=T<= 100

1 <= the length of S <= 100000

1 <= K <= 100000

Output

For each case, output a line contains the answer.

Sample Input

3

abc

1

abcabc

1

abcabc

2

Sample Output

6

15

21

官方题解:

1003 Boring count

枚举字符串下标i,每次计算以i为结尾的符合条件的最长串。那么以i为结尾的符合条件子串个数就是最长串的长度。求和即可。

计算以i为结尾的符合条件的最长串两种方法:

1.维护一个起点下标startPos,初始为1。如果当前为i,那么cnt[str[i]]++,如果大于k的话,就while( str[startPos] != str[i+1] ) cnt[str[startPos]]–, startPos++; 每次都保证 startPos~i区间每个字母个数都不超过k个。ans += ( i-startPos+1 )。 时间复杂度O(n)

自己当时怎么没有想到呢?

#include <set>
#include <map>
#include <list>
#include <stack>
#include <cmath>
#include <queue>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#define PI cos(-1.0)
#define RR freopen("input.txt","r",stdin)
using namespace std;
typedef long long LL;
const int Max= 100010;
char str[Max];
int vis[30];
int main()
{
int k;
int T;
int len;
LL sum;
scanf("%d",&T);
while(T--)
{
scanf("%s",str);
scanf("%d",&k);
memset(vis,0,sizeof(vis));
len = strlen(str);
int ans=0;
sum=0;
for(int i=0;i<len;i++)
{
vis[str[i]-'a']++;
while(vis[str[i]-'a']>k)
{
vis[str[ans]-'a']--;
ans++;
}
sum+=(i-ans+1); }
cout<<sum<<endl;
}
return 0;
}

最新文章

  1. 写入文件(txt格式)
  2. javascript各种宽高
  3. angularjs http 请求拦截器
  4. 高效 Java Web 开发框架 JessMA v3.3.1 Beta-1 发布
  5. Percona XtraBackup User Manual 阅读笔记
  6. iOS开发UI篇—Quartz2D使用(图形上下文栈)
  7. improve performance whilemaintaining the functionality of a simpler and more abstract model design of processor hardware
  8. 解决服务器复制中SID冲突问题
  9. php使用memcache与memcached扩展对key值的影响
  10. fpm打包redis3.0.7
  11. Java发送邮件的简单实现
  12. asp.net mvc4
  13. Prototype,创建型模式
  14. Think PHP 基础
  15. SpringMVC+Mybatis实现的Mysql分页数据查询
  16. Lombok 使用小结
  17. centos7 系统安装问题汇总
  18. python_IO编程
  19. BZOJ 4763
  20. MFC 修改标题

热门文章

  1. Java基础之一组有用的类——为标记定义自己的模式(ScanString)
  2. 学习jsp(1)
  3. C++Builder 笔记
  4. 多边形和圆的相交面积(模板)hdu2892、hdu4404
  5. 利用并查集求最大生成树和最小生成树(nlogn)
  6. [原创]java WEB学习笔记75:Struts2 学习之路-- 总结 和 目录
  7. SPOJ COT3 Combat on a tree(Trie树、线段树的合并)
  8. enum与typedef enum的用法
  9. UINavigationController详解三(转)ToolBar
  10. drupal 做301跳转(删除url里的www), 关键代码 可用到任何网站