A - Count on Canton

Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

1/1 1/2 1/3 1/4 1/5 ...

2/1 2/2 2/3 2/4
3/1 3/2 3/3
4/1 4/2
5/1

In
the above diagram, the first term is 1/1, the second term is 1/2, the
third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so
on.

Input

The input list contains a single number per line and will be terminated by endof-file.

Output

You are to write a program that will read a list of numbers in the
range from 1 to 10^7 and will print for each number the corresponding
term in Cantor's enumeration as given below.

Sample Input

3
14
7

Sample Output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4 代码:
#include <stdio.h>
#include <string.h> int main()
{
    int n;
    int i, j;
    int dd, ff;
    int d, c;     while(scanf("%d", &n)!=EOF )
    {
        d = 1;
        while(( (1+d)*d)/2 < n)
        {
            d++;
        }
        c = d-1;
        if(d%2==1)//奇数列
        {
            dd = d-( n-(1+c)*c/2 )+1 ;
            ff = n-(1+c)*c/2;
        }
        else if(d%2==0)//偶数列
        {
            dd = n-(1+c)*c/2 ;
            ff = d-( n-(1+c)*c/2 ) +1;
        }
        printf("TERM %d IS %d/%d\n", n, dd, ff );
    }
    return 0;
}

最新文章

  1. winform程序重启
  2. 腾讯企鹅智酷100多张PPT:移动时代创业黄金法则
  3. BeanFactory
  4. Android核心分析之二十七Android GDI 之SurfaceFlinger之动态结构示
  5. always语言指导原则
  6. JetBrains发布了一款免费的.NET反编译器dotPeek
  7. jQuery 元素移除empty() remove()与detach()的区别?
  8. jQuery的入门与简介《思维导图》
  9. 配置Tomcat
  10. 我的第一次Pascal程序
  11. 正确理解python的装饰器
  12. eclipse使用lombok简化java代码
  13. MySQL更新死锁问题【转,纯为学习】
  14. jQuery图片灯箱和视频灯箱
  15. Python基础【day03】:字符转编码操作(五)
  16. 异步加载script,提高前端性能(defer和async属性的区别)
  17. Thinkphp 全选、反选 批量删除
  18. java 将class打包成jar包
  19. ios 中局部变量可以通过传递来进行管理和释放,借此可提高代码的內聚度
  20. 利用burpsuite实现重放攻击

热门文章

  1. es快照和备份
  2. Hibernate学习之二级缓存
  3. spring事务管理实现方式
  4. Android使用SQLite数据库
  5. Hotel poj 3667
  6. mongodb 安装及使用
  7. 修改mysql数据库存储目录
  8. 【BZOJ4026】dC Loves Number Theory 分解质因数+主席树
  9. CAFFE学习笔记(四)将自己的jpg数据转成lmdb格式
  10. 【HTML5开发系列】meta元素详解