Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 38942   Accepted: 18247
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range
of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest
cow in the group.

Input

Line 1: Two space-separated integers, N andQ.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cowi

Lines N+2..N+Q+1: Two integers A and B (1 ≤A
BN), representing the range of cows from A toB inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver



题目大意:在一定区间内给定一些数。要求求出在某一区间内最大值和最小值的差。

线段树的题目。对于这道题目,既然是求最大值和最小值的差,那么必定要在区间里面存放最大值和最小值。同一时候这道题目仅仅是单纯的要求查询区间内的差值,不须要进行更新。

#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
#define min(a,b) a<b? a:b
#define INF 99999999
#define N 50005
struct tree{
int l,r,maxi,mini;
int mid(){
return l+r>>1;
}
}tree[N<<2];
int ma=-INF,mi=INF;
void build(int l,int r,int root)
{
tree[root].l=l;
tree[root].r=r;
tree[root].maxi=-INF;
tree[root].mini=INF; //初始化最大最小值
if(l==r){ return;
}
int mid=l+r>>1;
build(l,mid,root<<1);
build(mid+1,r,root<<1|1);
}
void update(int i,int z,int root)
{ if(tree[root].l==tree[root].r){
tree[root].mini=tree[root].maxi=z;
return;
}
tree[root].maxi=max(tree[root].maxi,z);
tree[root].mini=min(tree[root].mini,z); //每次都更新最大和最小值
if(i<=tree[root].mid())update(i,z,root<<1); //这里将i下面的节点所有更新。 而i与mid 是有关系的。
else update(i,z,root<<1|1);
}
void Query(int l,int r,int root)
{
if(tree[root].mini>=mi&&tree[root].maxi<=ma)return;
if(l==tree[root].l&&r==tree[root].r){
mi=min(mi,tree[root].mini);
ma=max(ma,tree[root].maxi);
return;
}
int mid=tree[root].l+tree[root].r>>1;
if(r<=mid){
Query(l,r,root<<1);
}
else if(l>mid){
Query(l,r,root<<1|1);
}
else {
Query(l,mid,root<<1);
Query(mid+1,r,root<<1|1);
}
return ;
}
int main()
{
int n,Q,cow[200005],a,b;
int i,j,k;
while(scanf("%d%d",&n,&Q)!=EOF)
{
build(1,n,1);
for(i=1;i<=n;i++)
{
scanf("%d",&cow[i]);
update(i,cow[i],1); //对于第i个数字进行插入
} while(Q--)
{
scanf("%d%d",&a,&b);
ma=-INF;
mi=INF;
Query(a,b,1);
printf("%d\n",ma-mi);
}
}
return 0;
}

最新文章

  1. golang-web框架revel一个表单提交的总结
  2. Webform 上传图片加水印
  3. hdu 2043
  4. com组件的注册
  5. star
  6. arcgis gdb含下划线_和%的查询 by gisoracle
  7. 省常中模拟 Test3 Day2
  8. KNN及其改进算法的python实现
  9. 使用 Windows 窗体 TextBox 控件创建密码文本框
  10. WebSocket使用教程 - 带完整实例
  11. java_内存划分
  12. cf472C Design Tutorial: Make It Nondeterministic
  13. android开发之多线程实现方法概述
  14. live-server 介绍&amp;安装
  15. 基于create-react-app的再配置
  16. 自学Python之路-Python核心编程
  17. jquery 判断元素是否可见
  18. Facelets应用程序的生命周期
  19. 1. eclipse异常问题解决办法
  20. [转]C++ STL list的初始化、添加、遍历、插入、删除、查找、排序、释放

热门文章

  1. iptables不小心把127.0.0.1封了,导致redis连不上
  2. Servlet3.0提供的异步处理
  3. spring java 方式配置JedisPool Bean
  4. 安卓新闻client笔记积累
  5. 新闻焦点切换flash应用
  6. Centos 7 通过yum的方式安装配置Artifactory 5.10
  7. java调用机器上的shell脚本
  8. Windows Vista如何让梦幻桌面支持更多格式
  9. 深入分析JavaWeb Item24 -- jsp2.X自己定义标签开发进阶
  10. Mach-O文件格式和程序从载入到运行过程