题目描述

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John's field, determine how many ponds he has.

由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个NxM(1<=N<=100;1<=M<=100)网格图表示。每个网格中有水('W') 或是旱地('.')。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

输入输出格式

输入格式:

Line 1: Two space-separated integers: N and M * Lines 2..N+1: M
characters per line representing one row of Farmer John's field. Each
character is either 'W' or '.'. The characters do not have spaces
between them.

第1行:两个空格隔开的整数:N 和 M 第2行到第N+1行:每行M个字符,每个字符是'W'或'.',它们表示网格图中的一排。字符之间没有空格。

输出格式:

Line 1: The number of ponds in Farmer John's field.

一行:水坑的数量

输入输出样例

输入样例#1:
复制

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
输出样例#1: 复制

3

说明

OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#include<cctype>
//#pragma GCC optimize(2)
using namespace std;
#define maxn 1000005
#define inf 0x7fffffff
//#define INF 1e18
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9 + 7;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-4
typedef pair<int, int> pii;
#define pi acos(-1.0)
//const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)
typedef pair<int, int> pii;
inline ll rd() {
ll x = 0;
char c = getchar();
bool f = false;
while (!isdigit(c)) {
if (c == '-') f = true;
c = getchar();
}
while (isdigit(c)) {
x = (x << 1) + (x << 3) + (c ^ 48);
c = getchar();
}
return f ? -x : x;
} ll gcd(ll a, ll b) {
return b == 0 ? a : gcd(b, a%b);
}
int sqr(int x) { return x * x; } /*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {
if (!b) {
x = 1; y = 0; return a;
}
ans = exgcd(b, a%b, x, y);
ll t = x; x = y; y = t - a / b * y;
return ans;
}
*/ int n, m;
char ch[200][200];
int tot;
int a[200][200];
bool vis[200][200];
int dx[] = { 1,1,1,-1,-1,-1,0,0 };
int dy[] = { 0,1,-1,0,1,-1,1,-1 }; void dfs(int x, int y,int id) {
vis[x][y] = id;
for (int i = 0; i < 8; i++) {
int nx = x + dx[i];
int ny = y + dy[i];
if (!vis[nx][ny] && a[nx][ny] == 1) {
dfs(nx, ny, id);
}
}
} int main() {
//ios::sync_with_stdio(0);
rdint(n); rdint(m);
for (int i = 1; i <= n; i++)scanf("%s", ch[i] + 1);
for (int i = 1; i <= n; i++)
for (int j = 1; j <= m; j++)
if (ch[i][j] == 'W')a[i][j] = 1;
for (int i = 1; i <= n; i++) {
for (int j = 1; j <= m; j++) {
if (a[i][j] == 1 && !vis[i][j]) {
dfs(i, j, ++tot);
}
}
}
cout << tot << endl;
return 0;
}

最新文章

  1. Leetcode Simplify Path
  2. Cheminformatic Set
  3. poj 2891 扩展欧几里得迭代解同余方程组
  4. 【BZOJ】【2565】最长双回文串
  5. angular的$q服务和promise模式
  6. cocos2d-x游戏开发系列教程-中国象棋04-摆棋
  7. 中文乱码?不,是 HTML 实体编码!(转)
  8. Django - 模型表单(创建、更新、删除)
  9. centos7 LNMP
  10. Spring的事务初见
  11. MT【307】周期数列
  12. CA证书和TLS介绍
  13. Windows 的 Oracle Data Access Components (ODAC)
  14. python学习之老男孩python全栈第九期_day025知识点总结——接口类、抽象类、多态、封装
  15. iOS通讯录相关知识-浅析
  16. WSO2 API Manager中host Ip 不正确的问题解决方法
  17. Springboot入门-日志框架配置(转载)
  18. Bootstrap后台管理模板调研
  19. 692. Top K Frequent Words
  20. Codeforces 463D Gargari and Permutations:隐式图dp【多串LCS】

热门文章

  1. MyBatis----延迟加载demo
  2. python 函数对象、函数嵌套、名称空间与作用域、装饰器
  3. 将openfire部署到CentOS云服务器上
  4. 部署和调优 3.1 dns安装配置-1
  5. Yahoo浮沉录
  6. android手机分辨率的一些说明
  7. Java开源中文分词类库
  8. cocos2d-js 热更新模块 使用AssetsManager
  9. 算法Sedgewick第四版-第1章基础-021一双向链表,在遍历时可修改、删除元素
  10. Java-马士兵设计模式学习笔记-策略模式-模拟 Comparator接口