https://pintia.cn/problem-sets/994805342720868352/problems/994805451374313472

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 − }, and a set of product values { 7 6 − − } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​product values. Here 1, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

代码:

#include <bits/stdc++.h>
using namespace std; const int maxn = 1e5 + 10;
int N, M;
int a[maxn], b[maxn], c[maxn], d[maxn];
int v1[maxn], v2[maxn];
int num1 = 0, num2 = 0, num3 = 0, num4 = 0; bool cmp(int x, int y) {
return x > y;
} int main() {
scanf("%d", &N);
for(int i = 1; i <= N; i ++) {
scanf("%d", &v1[i]);
if(v1[i] >= 0)
a[num1 ++] = v1[i];
else
b[num2 ++] = v1[i];
}
scanf("%d", &M);
for(int i = 1; i <= M; i ++) {
scanf("%d", &v2[i]);
if(v2[i] >= 0)
c[num3 ++] = v2[i];
else
d[num4 ++] = v2[i];
} sort(a, a + num1, cmp);
sort(b, b + num2);
sort(c, c + num3, cmp);
sort(d, d + num4); int len1 = min(num1, num3);
int len2 = min(num2, num4); int sum = 0;
for(int i = 0; i < len1; i ++) {
sum += a[i] * c[i];
}
for(int i = 0; i < len2; i ++) {
if(b[i] * d[i] >= 0)
sum += b[i] * d[i];
}
printf("%d\n", sum);
return 0;
}

  

最新文章

  1. 遇到一位ITer,一位出租车司机,必看。
  2. JavaScript中如何中断forEach循环
  3. pyhton Chapter3 读文件
  4. ArrayList与LinkedList实现比较
  5. 利用servlet做转发,实现js跨域解决同源问题
  6. wcf客户端捕获异常
  7. error2
  8. java list三种遍历方法性能比较
  9. redisTemplate keys方法 为空
  10. 如何通过 HSB 颜色模式构建夜间模式
  11. [bzoj 2243]: [SDOI2011]染色 [树链剖分][线段树]
  12. 计算机和HMI设备通信之程序上下载
  13. 转:rabbitMQ 安装与管理
  14. MySQL 大数据量快速插入方法和语句优化
  15. Npoi简单读写Excel
  16. Swagger UI 用法
  17. CRT和EXCRT学习笔记
  18. u-boot(五)内核启动
  19. c#判断是否有网络
  20. nginx、tomcat调优方向及压测网站步骤

热门文章

  1. IE问题——列表项图像
  2. window下绝对路径
  3. MFC项目依赖 BCG框架示例
  4. C++声明之CV限定符
  5. Linux基础知识随笔记
  6. kickstart+pxe+tftp+ntp(http)自动化安装平台的搭建
  7. 时间轮算法的定时器(Delphi)
  8. flask-login原理详解
  9. SPOJ1026 概率DP
  10. Oozie 实战之 Hive