Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19010    Accepted Submission(s): 7507

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The
input contains several test cases. The first line of the input is a
single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

 
Author
Ignatius.L
【分析】:
【代码】:
#include <bits/stdc++.h>
using namespace std; typedef long long LL;
const int MOD = ;
typedef vector<LL> vec;
typedef vector<vec> mat; int main()
{
int n,t,ans;
double tmp;
cin>>t;
while(t--){
cin>>n;
tmp=n*log10(1.0*n);
tmp=tmp-(__int64)tmp;
ans=(int)(pow(10.0,tmp));
printf("%d\n",ans);
}
return ;
}

数论

最新文章

  1. [Erlang 0126] 我们读过的Erlang论文
  2. tomcat出现的PermGen Space问题
  3. 【算法】简单动态规划——三逆数的O(N^2)解法!
  4. PPAS上运行pg_dump经过II
  5. Cycling
  6. ZOJ-2965
  7. BZOJ.4160.[NEERC2009]Exclusive Access 2(状压DP Dilworth定理)
  8. richedit缩放
  9. SSH 协议的 ssh StrictHostKeyChecking
  10. VS Code折腾记 - (2) 快捷键大全,没有更全
  11. 安装IIS
  12. save
  13. python---django中url访问方法
  14. 品鉴同事发来的炸金花的PHP程序代码
  15. 2018.06.30 BZOJ3083: 遥远的国度(换根树剖)
  16. Linux内存管理(text、rodata、data、bss、stack&amp;heap)
  17. (转) 打开声音设备需要使用waveOutOpen函数
  18. lambda distinct
  19. Jsp遍历后台传过来的List
  20. gentoo emerge unable to sync

热门文章

  1. 从头开始学习数据库及ADO.NET之PostgreSql字段约束——竹子整理
  2. java十分钟速懂知识点——System类
  3. 使用chrome开发程序,自动刷新开发目录
  4. P3398 仓鼠找sugar(树链剖分)
  5. TCP/IP网络编程之多播与广播
  6. Hive将SQL转化为MapReduce的过程
  7. “帮你APP”团队冲刺4
  8. Java学习3之成员方法及函数重载
  9. Linux互斥锁、条件变量和信号量
  10. PHP算法面试题目